summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorZang Ruochen <zangrc.fnst@cn.fujitsu.com>2020-09-30 12:05:15 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-10-22 12:56:52 +0100
commit5a0237ad40457bbaedcc3f0e6c130612981eece3 (patch)
treea96455249dfeb15d42bb435b2334dceddd24b62a /meta
parent082902a3e97020f0b02097feb3c2173c64a017bf (diff)
downloadopenembedded-core-contrib-5a0237ad40457bbaedcc3f0e6c130612981eece3.tar.gz
harfbuzz: Refresh patch
Because two modifications conflict in the patch, do_patch will make an error when using patch as a patchtool. Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-graphics/harfbuzz/harfbuzz/version-race.patch76
1 files changed, 26 insertions, 50 deletions
diff --git a/meta/recipes-graphics/harfbuzz/harfbuzz/version-race.patch b/meta/recipes-graphics/harfbuzz/harfbuzz/version-race.patch
index 2d692f36b5..a8b8f0353c 100644
--- a/meta/recipes-graphics/harfbuzz/harfbuzz/version-race.patch
+++ b/meta/recipes-graphics/harfbuzz/harfbuzz/version-race.patch
@@ -1,24 +1,35 @@
-Upstream-Status: Backport [https://github.com/harfbuzz/harfbuzz/commit/5aff83104e03d6d2617987d24a51e490ab7a5cd1]
-Signed-off-by: Ross Burton <ross.burton@arm.com>
-
-From bc1c93fbe04459a4b12c76c713ba1b750d2d9108 Mon Sep 17 00:00:00 2001
-From: Ross Burton <ross.burton@arm.com>
-Date: Mon, 7 Sep 2020 17:11:17 +0100
-Subject: [PATCH 1/2] [build] No need to pass source directory to
- gen-hb-version
+From 6ccadec1fae6a73749b7dfe2311f71d0e610e812 Mon Sep 17 00:00:00 2001
+From: Zang Ruochen <zangrc.fnst@cn.fujitsu.com>
+Date: Wed, 30 Sep 2020 10:30:08 +0900
+Subject: [PATCH] No need to pass source directory to gen-hb-version
The input file is by definition in the source directory, so dirname()
that instead of needing the directory to be passed.
Needed because a follow-up commit will change when this is called, and the
source directory isn't trivially available at that point.
+
+generate hb-version.h once at configure time with Meson
+
+Currently with Meson hb-version.h is generated during the build without
+any explicit dependencies which can result in build failures due races
+over the file.
+
+Change this to be generated at configure time, so that the file is always
+generated once before the build itself.
+
+Closes #2667
+
+Upstream-Status: Backport [https://github.com/harfbuzz/harfbuzz/commit/5aff83104e03d6d2617987d24a51e490ab7a5cd1]
+Signed-off-by: Ross Burton <ross.burton@arm.com>
+Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com>
---
- src/gen-hb-version.py | 6 +++---
- src/meson.build | 2 +-
- 2 files changed, 4 insertions(+), 4 deletions(-)
+ src/gen-hb-version.py | 6 +++---
+ src/meson.build | 17 ++++++++---------
+ 2 files changed, 11 insertions(+), 12 deletions(-)
diff --git a/src/gen-hb-version.py b/src/gen-hb-version.py
-index 15e56b93..bf16f88a 100755
+index 15e56b9..bf16f88 100755
--- a/src/gen-hb-version.py
+++ b/src/gen-hb-version.py
@@ -4,15 +4,15 @@
@@ -41,42 +52,7 @@ index 15e56b93..bf16f88a 100755
with open (INPUT, "r", encoding='utf-8') as template:
with open (OUTPUT, "wb") as output:
diff --git a/src/meson.build b/src/meson.build
-index 5d7cd578..2d78c992 100644
---- a/src/meson.build
-+++ b/src/meson.build
-@@ -286,7 +286,7 @@ custom_target('hb-version.h',
- input: 'hb-version.h.in',
- output: 'hb-version.h',
- command: [find_program('gen-hb-version.py'), meson.project_version(),
-- '@OUTPUT@', '@CURRENT_SOURCE_DIR@', '@INPUT@'],
-+ '@OUTPUT@', '@INPUT@'],
- )
-
- ragel = find_program('ragel', required: false)
---
-2.28.0
-
-
-From 5aff83104e03d6d2617987d24a51e490ab7a5cd1 Mon Sep 17 00:00:00 2001
-From: Ross Burton <ross.burton@arm.com>
-Date: Mon, 7 Sep 2020 10:55:33 +0100
-Subject: [PATCH 2/2] [build] generate hb-version.h once at configure time with
- Meson
-
-Currently with Meson hb-version.h is generated during the build without
-any explicit dependencies which can result in build failures due races
-over the file.
-
-Change this to be generated at configure time, so that the file is always
-generated once before the build itself.
-
-Closes #2667
----
- src/meson.build | 17 ++++++++---------
- 1 file changed, 8 insertions(+), 9 deletions(-)
-
-diff --git a/src/meson.build b/src/meson.build
-index 2d78c992..19290245 100644
+index 5e1787c..56d8ae2 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -1,3 +1,10 @@
@@ -110,12 +86,12 @@ index 2d78c992..19290245 100644
- input: 'hb-version.h.in',
- output: 'hb-version.h',
- command: [find_program('gen-hb-version.py'), meson.project_version(),
-- '@OUTPUT@', '@INPUT@'],
+- '@OUTPUT@', '@CURRENT_SOURCE_DIR@', '@INPUT@'],
-)
-
ragel = find_program('ragel', required: false)
if not ragel.found()
warning('You have to install ragel if you are going to develop HarfBuzz itself')
--
-2.28.0
+2.25.1