aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-12-31 17:04:56 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-01-03 12:10:48 +0000
commitf1b2d49d0cc6f1b75f0870941d8c7ce742378d4d (patch)
treeede38e91bdc90bd0c573b3abd327615fad7a6a1f /meta
parentc0db889441f16232c59c85a8a858bb833bb34b52 (diff)
downloadopenembedded-core-contrib-f1b2d49d0cc6f1b75f0870941d8c7ce742378d4d.tar.gz
procps: raise update-alternatives priority
This fixes a problem with the uptime utility: root@beagleboneA3-0088:/var/lib/cloud9# busybox uptime 16:00:17 up 2 days, 6:46, load average: 0.14, 0.04, 0.05 root@beagleboneA3-0088:/var/lib/cloud9# uptime.procps 16:00:22 up 2 days, 6:46, 1 user, load average: 0.14, 0.05, 0.06 root@beagleboneA3-0088:/var/lib/cloud9# uptime.coreutils 16:00pm up 4382 days 15:58, 1 user, load average: 0.13, 0.05, 0.05 root@beagleboneA3-0088:/var/lib/cloud9# ls /usr/bin/uptime -la lrwxrwxrwx 1 root root 16 Dec 26 08:56 /usr/bin/uptime -> uptime.coreutils Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-extended/procps/procps_3.2.8.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-extended/procps/procps_3.2.8.bb b/meta/recipes-extended/procps/procps_3.2.8.bb
index d989955f62..6a41ccdef9 100644
--- a/meta/recipes-extended/procps/procps_3.2.8.bb
+++ b/meta/recipes-extended/procps/procps_3.2.8.bb
@@ -1,12 +1,12 @@
require procps.inc
-PR = "r3"
+PR = "r4"
inherit update-alternatives
ALTERNATIVE_LINKS = "${bindir}/top ${bindir}/uptime ${bindir}/free ${bindir}/pkill ${bindir}/pmap \
${base_bindir}/kill ${base_sbindir}/sysctl ${base_bindir}/ps"
-ALTERNATIVE_PRIORITY = "90"
+ALTERNATIVE_PRIORITY = "110"
SRC_URI += "file://procmodule.patch \
file://psmodule.patch \