summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRicardo Ribalda Delgado <ricardo.ribalda@gmail.com>2015-09-01 16:28:28 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-09-01 21:08:15 +0100
commit610baaca41ede3a2a9697d1b34bbca6c6fa1da11 (patch)
tree1b7aa4f37b905352afcb174c11ecd5335cd73d4d /meta
parent6b918dc24d4ab6dcc3693f7f8a8653535edb58c0 (diff)
downloadopenembedded-core-contrib-610baaca41ede3a2a9697d1b34bbca6c6fa1da11.tar.gz
python: Fix python-distutils variables
python-distutils uses the information from this file for setting the system variables. Whithout this patch: root@qt5022:~# pip install pyzmq ... x86_64-poky-linux-gcc -m64 -march=btver1 -mtune=btver1 --sysroot=/var/lib/jenkins/jobs/qt5022-cesium/workspace/build/tmp/sysroots/qt5022 -fno-strict-aliasing -O2 -pipe -g -feliminate-unused-debug-types -DNDEBUG -g -O3 -Wall -Wstrict-prototypes -fPIC -DNATIVE_LITTLE_ENDIAN=1 -Ibundled/libsodium/src/libsodium/include -Ibundled/libsodium/src/libsodium/include/sodium -I/usr/include/python2.7 -c buildutils/initlibsodium.c -o build/temp.linux-x86_64-2.7/buildutils/initlibsodium.o In file included from /usr/include/python2.7/Python.h:8:0, from buildutils/initlibsodium.c:10: /usr/include/python2.7/pyconfig.h:24:27: fatal error: bits/wordsize.h: No such file or directory #include <bits/wordsize.h> root@qt5022:~# ls /usr/include/bits/wordsize.h /usr/include/bits/wordsize.h Signed-off-by: Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/python/python_2.7.9.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/meta/recipes-devtools/python/python_2.7.9.bb b/meta/recipes-devtools/python/python_2.7.9.bb
index 803a1fc749..ae45577165 100644
--- a/meta/recipes-devtools/python/python_2.7.9.bb
+++ b/meta/recipes-devtools/python/python_2.7.9.bb
@@ -137,8 +137,10 @@ py_package_preprocess () {
# copy back the old Makefile to fix target package
install -m 0644 ${B}/Makefile.orig ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/config/Makefile
- # Remove references to buildmachine paths in target Makefile
- sed -i -e 's:--sysroot=${STAGING_DIR_TARGET}::g' -e s:'--with-libtool-sysroot=${STAGING_DIR_TARGET}'::g ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/config/Makefile
+ # Remove references to buildmachine paths in target Makefile and _sysconfigdata
+ sed -i -e 's:--sysroot=${STAGING_DIR_TARGET}::g' -e s:'--with-libtool-sysroot=${STAGING_DIR_TARGET}'::g \
+ ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/config/Makefile \
+ ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/_sysconfigdata.py
}
require python-${PYTHON_MAJMIN}-manifest.inc