aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-11-16 10:56:17 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2009-11-16 10:56:17 +0000
commit7acfa9467f7acb4d15663ed81b46cc88fd1bd6a8 (patch)
treedf62c5b38a72b8f2b654e6d17ed1204763c26ce7 /meta
parent5c0111cb9db0162d111eed41540de6a702b68e58 (diff)
downloadopenembedded-core-contrib-7acfa9467f7acb4d15663ed81b46cc88fd1bd6a8.tar.gz
perl: Standardise config.sh location
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/classes/cpan-base.bbclass2
-rw-r--r--meta/classes/cpan.bbclass4
-rw-r--r--meta/classes/cpan_build.bbclass2
-rw-r--r--meta/packages/perl/perl-native_5.8.8.bb6
-rw-r--r--meta/packages/perl/perl.inc4
-rw-r--r--meta/packages/perl/perl_5.8.8.bb5
6 files changed, 12 insertions, 11 deletions
diff --git a/meta/classes/cpan-base.bbclass b/meta/classes/cpan-base.bbclass
index 919a9b06a5..82fd5b459a 100644
--- a/meta/classes/cpan-base.bbclass
+++ b/meta/classes/cpan-base.bbclass
@@ -10,7 +10,7 @@ RDEPENDS += "${@["perl", ""][(bb.data.inherits_class('native', d))]}"
# Determine the staged version of perl from the perl configuration file
def get_perl_version(d):
import re
- cfg = bb.data.expand('${STAGING_DIR}/${HOST_SYS}/perl/config.sh', d)
+ cfg = bb.data.expand('${STAGING_LIBDIR}/perl/config.sh', d)
try:
f = open(cfg, 'r')
except IOError:
diff --git a/meta/classes/cpan.bbclass b/meta/classes/cpan.bbclass
index ca5303d97f..66054bc755 100644
--- a/meta/classes/cpan.bbclass
+++ b/meta/classes/cpan.bbclass
@@ -10,11 +10,13 @@ export PERLCONFIGTARGET = "${@is_target(d)}"
# Env var which tells perl where the perl include files are
export PERL_INC = "${STAGING_LIBDIR}/perl/${@get_perl_version(d)}/CORE"
+export PERL_LIB = "${STAGING_DATADIR}/perl/${@get_perl_version(d)}"
+export PERL_ARCHLIB = "${STAGING_LIBDIR}/perl/${@get_perl_version(d)}"
cpan_do_configure () {
yes '' | perl Makefile.PL ${EXTRA_CPANFLAGS}
if [ "${BUILD_SYS}" != "${HOST_SYS}" ]; then
- . ${STAGING_DIR}/${TARGET_SYS}/perl/config.sh
+ . ${STAGING_LIBDIR}/perl/config.sh
if [ "${IS_NEW_PERL}" = "yes" ]; then
sed -i -e "s:\(SITELIBEXP = \).*:\1${sitelibexp}:" \
-e "s:\(SITEARCHEXP = \).*:\1${sitearchexp}:" \
diff --git a/meta/classes/cpan_build.bbclass b/meta/classes/cpan_build.bbclass
index 9cfe72bcb7..6cac85c5fe 100644
--- a/meta/classes/cpan_build.bbclass
+++ b/meta/classes/cpan_build.bbclass
@@ -22,7 +22,7 @@ DEPENDS_prepend = "${@cpan_build_dep_prepend(d)}"
cpan_build_do_configure () {
if [ ${@is_target(d)} == "yes" ]; then
# build for target
- . ${STAGING_DIR}/${TARGET_SYS}/perl/config.sh
+ . ${STAGING_LIBDIR}/perl/config.sh
if [ "${IS_NEW_PERL}" = "yes" ]; then
perl Build.PL --installdirs vendor \
--destdir ${D} \
diff --git a/meta/packages/perl/perl-native_5.8.8.bb b/meta/packages/perl/perl-native_5.8.8.bb
index e2bdaee30a..fb8be281bf 100644
--- a/meta/packages/perl/perl-native_5.8.8.bb
+++ b/meta/packages/perl/perl-native_5.8.8.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.perl.org/"
SECTION = "libs"
LICENSE = "Artistic|GPL"
DEPENDS = "virtual/db-native gdbm-native"
-PR = "r13"
+PR = "r14"
SRC_URI = "http://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz \
file://perl-5.8.8-gcc-4.2.patch;patch=1 \
@@ -61,8 +61,8 @@ do_stage_append() {
# We need a hostperl link for building perl
ln -sf ${STAGING_BINDIR_NATIVE}/perl${PV} ${STAGING_BINDIR_NATIVE}/hostperl
# Store native config in non-versioned directory
- install -d ${STAGING_DIR}/${HOST_SYS}/perl
- install config.sh ${STAGING_DIR}/${HOST_SYS}/perl
+ install -d ${STAGING_LIBDIR}/perl
+ install config.sh ${STAGING_LIBDIR}/perl
}
PARALLEL_MAKE = ""
diff --git a/meta/packages/perl/perl.inc b/meta/packages/perl/perl.inc
index 9e20ae63e6..15ae55cf17 100644
--- a/meta/packages/perl/perl.inc
+++ b/meta/packages/perl/perl.inc
@@ -36,8 +36,8 @@ do_install() {
}
do_stage() {
- install -d ${STAGING_DIR}/${HOST_SYS}/perl/
- install config.sh ${STAGING_DIR}/${HOST_SYS}/perl/
+ install -d ${STAGING_LIBDIR}/perl/
+ install config.sh ${STAGING_LIBDIR}/perl/
}
PACKAGES_DYNAMIC = "perl-module-*"
diff --git a/meta/packages/perl/perl_5.8.8.bb b/meta/packages/perl/perl_5.8.8.bb
index 977852ac21..0696de577f 100644
--- a/meta/packages/perl/perl_5.8.8.bb
+++ b/meta/packages/perl/perl_5.8.8.bb
@@ -137,11 +137,10 @@ do_install() {
fi
}
do_stage() {
- install -d ${STAGING_DIR}/${HOST_SYS}/perl \
- ${STAGING_LIBDIR_NATIVE}/perl/${PV} \
+ install -d ${STAGING_LIBDIR_NATIVE}/perl/${PV} \
${STAGING_LIBDIR}/perl/${PV}/CORE
# target config, used by cpan.bbclass to extract version information
- install config.sh ${STAGING_DIR}/${HOST_SYS}/perl/
+ install config.sh ${STAGING_LIBDIR}/perl/
# target configuration, used by native perl when cross-compiling
install lib/Config_heavy.pl ${STAGING_LIBDIR_NATIVE}/perl/${PV}/Config_heavy-target.pl
# perl shared library headers