aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorSerhey Popovych <serhe.popovych@gmail.com>2018-12-14 19:54:38 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-12-15 17:10:44 +0000
commitb2ec91e12088afa0560aecede587d0970fc64110 (patch)
tree9802ed10adda4860a70230c0b16b12fdea2aecd5 /meta
parentbee9e807430178426b2a5635b573ae285e889c39 (diff)
downloadopenembedded-core-contrib-b2ec91e12088afa0560aecede587d0970fc64110.tar.gz
python3: Fix do_configure check platform triplet error (2)
When building for powerpc 32bit with musl following error triggered from do_configure: checking for the platform triplet based on compiler characteristics... powerpc-linux-gnu configure: error: internal configure error for the platform triplet, please file a bug report This is caused by PLATFORM_TRIPLET != MULTIARCH mismatch since MULTIARCH in case of musl is powerpc-linux-musl. Since triplet is used as part module name as described in PEP-3149 to make fix less intrusive alias powerpc-linux-musl to powerpc-linux-gnu to avoid possible runtime (e.g. tests) incompatibilities later. Fix was inspired by commit cda0ef61d373 ("python3: fix do_configure check platform triplet error"). Signed-off-by: Serhey Popovych <serhe.popovych@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/python/python3/tweak-MULTIARCH-for-powerpc-linux-musl.patch40
-rw-r--r--meta/recipes-devtools/python/python3_3.5.6.bb1
2 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3/tweak-MULTIARCH-for-powerpc-linux-musl.patch b/meta/recipes-devtools/python/python3/tweak-MULTIARCH-for-powerpc-linux-musl.patch
new file mode 100644
index 0000000000..34c91755ff
--- /dev/null
+++ b/meta/recipes-devtools/python/python3/tweak-MULTIARCH-for-powerpc-linux-musl.patch
@@ -0,0 +1,40 @@
+From 7362464383bbd54f8e6be4389f2c74c0717bc6e1 Mon Sep 17 00:00:00 2001
+From: Serhey Popovych <serhe.popovych@gmail.com>
+Date: Sat, 8 Dec 2018 11:24:06 -0500
+Subject: [PATCH] configure.ac: tweak MULTIARCH for powerpc-linux-musl
+
+For musl builds, the MULTIARCH is powerpc-linux-musl and configure.ac
+does not have lines to recognize it causing configure error for the
+platform triplet when building for powerpc 32bit.
+
+This is feature described in PEP-3149 and to prevent possible runtime
+compatibility issues we map powerpc-linux-musl to powerpc-linux-gnu.
+
+Look at similar change by Hongxu Jia <hongxu.jia@> presended in
+tweak-MULTIARCH-for-powerpc-linux-gnuspe.patch to handle p1022ds BSP
+builds.
+
+Upstream-Status: Pending
+Signed-off-by: Serhey Popovych <serhe.popovych@gmail.com>
+---
+ configure.ac | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/configure.ac b/configure.ac
+index 95c98d1..1a4d8aa 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -752,6 +752,10 @@ if test x$MULTIARCH = xpowerpc-linux-gnuspev1
+ then
+ MULTIARCH="powerpc-linux-gnuspe"
+ fi
++if test x$MULTIARCH = xpowerpc-linux-musl
++then
++ MULTIARCH="powerpc-linux-gnu"
++fi
+
+ AC_SUBST(MULTIARCH)
+
+--
+2.7.4
+
diff --git a/meta/recipes-devtools/python/python3_3.5.6.bb b/meta/recipes-devtools/python/python3_3.5.6.bb
index cd7991e7f8..b4f6e55535 100644
--- a/meta/recipes-devtools/python/python3_3.5.6.bb
+++ b/meta/recipes-devtools/python/python3_3.5.6.bb
@@ -13,6 +13,7 @@ file://130-readline-setup.patch \
file://150-fix-setupterm.patch \
file://0001-h2py-Fix-issue-13032-where-it-fails-with-UnicodeDeco.patch \
file://tweak-MULTIARCH-for-powerpc-linux-gnuspe.patch \
+file://tweak-MULTIARCH-for-powerpc-linux-musl.patch \
file://support_SOURCE_DATE_EPOCH_in_py_compile.patch \
${DISTRO_SRC_URI} \
"