aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-08-19 00:51:01 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-08-24 23:43:25 +0100
commit7daac5798ac9e64efe00d8fca3adc463858a185d (patch)
tree344981d18e66b08012e4f630d3b85f47390e236b /meta
parent1f7aaf76f4aa7875f05f4b838a5ec4594a4c35dc (diff)
downloadopenembedded-core-contrib-7daac5798ac9e64efe00d8fca3adc463858a185d.tar.gz
glibc: use cross-rpcgen to replace host's rpcgen
There might be unexpected errors when use host's rpcgen. [YOCTO #8181] Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-core/glibc/glibc_2.22.bb6
1 files changed, 1 insertions, 5 deletions
diff --git a/meta/recipes-core/glibc/glibc_2.22.bb b/meta/recipes-core/glibc/glibc_2.22.bb
index 6aaf72260a..f0e1fad450 100644
--- a/meta/recipes-core/glibc/glibc_2.22.bb
+++ b/meta/recipes-core/glibc/glibc_2.22.bb
@@ -97,10 +97,6 @@ do_configure () {
# calls for now
# don't pass CPPFLAGS into configure, since it upsets the kernel-headers
# version check and doesn't really help with anything
- if [ -z "`which rpcgen`" ]; then
- echo "rpcgen not found. Install glibc-devel."
- exit 1
- fi
(cd ${S} && gnu-configize) || die "failure in running gnu-configize"
find ${S} -name "configure" | xargs touch
CPPFLAGS="" oe_runconf
@@ -119,7 +115,7 @@ do_compile () {
for r in ${rpcsvc}; do
h=`echo $r|sed -e's,\.x$,.h,'`
rm -f $h
- rpcgen -h $r -o $h || bbwarn "${PN}: unable to generate header for $r"
+ ${B}/sunrpc/cross-rpcgen -h $r -o $h || bbwarn "${PN}: unable to generate header for $r"
done
)
echo "Adjust ldd script"