aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2015-06-10 15:39:40 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-08-24 23:43:28 +0100
commit0f9ea90dde8f63aace19531e066580e41bf3d7cc (patch)
tree011b40d2f2d212b09fa915dbedea446408fa48dd /meta
parent4c76dd4ee10e3be147951824a4c082f271f90e62 (diff)
downloadopenembedded-core-contrib-0f9ea90dde8f63aace19531e066580e41bf3d7cc.tar.gz
classes/gnomebase: change tarball compression to xz
Upstream, xz has been the only format for some time now, so let's make it the default and adjust recipes that package old stuff. Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/classes/gnomebase.bbclass2
-rw-r--r--meta/recipes-core/glib-networking/glib-networking_2.44.0.bb2
-rw-r--r--meta/recipes-gnome/gnome/gnome-common_3.14.0.bb2
-rw-r--r--meta/recipes-gnome/gnome/gnome-doc-utils_0.20.10.bb2
-rw-r--r--meta/recipes-gnome/gnome/gnome-mime-data_2.18.0.bb1
-rw-r--r--meta/recipes-gnome/gtk-engines/gtk-engines_2.20.2.bb1
-rw-r--r--meta/recipes-gnome/json-glib/json-glib_1.0.4.bb2
-rw-r--r--meta/recipes-gnome/libglade/libglade_2.6.4.bb1
-rw-r--r--meta/recipes-gnome/librsvg/librsvg_2.40.10.bb2
-rw-r--r--meta/recipes-graphics/pango/pango_1.36.8.bb2
-rw-r--r--meta/recipes-support/atk/atk_2.16.0.bb2
-rw-r--r--meta/recipes-support/libcroco/libcroco_0.6.8.bb2
-rw-r--r--meta/recipes-support/vte/vte_0.28.2.bb4
13 files changed, 6 insertions, 19 deletions
diff --git a/meta/classes/gnomebase.bbclass b/meta/classes/gnomebase.bbclass
index fa8f88dd58..d22ba5a5cc 100644
--- a/meta/classes/gnomebase.bbclass
+++ b/meta/classes/gnomebase.bbclass
@@ -1,7 +1,7 @@
def gnome_verdir(v):
return oe.utils.trim_version(v, 2)
-GNOME_COMPRESS_TYPE ?= "bz2"
+GNOME_COMPRESS_TYPE ?= "xz"
SECTION ?= "x11/gnome"
GNOMEBN ?= "${BPN}"
SRC_URI = "${GNOME_MIRROR}/${GNOMEBN}/${@gnome_verdir("${PV}")}/${GNOMEBN}-${PV}.tar.${GNOME_COMPRESS_TYPE};name=archive"
diff --git a/meta/recipes-core/glib-networking/glib-networking_2.44.0.bb b/meta/recipes-core/glib-networking/glib-networking_2.44.0.bb
index 848bf53db2..4f91b76acf 100644
--- a/meta/recipes-core/glib-networking/glib-networking_2.44.0.bb
+++ b/meta/recipes-core/glib-networking/glib-networking_2.44.0.bb
@@ -9,8 +9,6 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
SECTION = "libs"
DEPENDS = "glib-2.0 intltool-native"
-GNOME_COMPRESS_TYPE = "xz"
-
SRC_URI[archive.md5sum] = "6989b20cf3b26dd5ae272e04a9acb0b3"
SRC_URI[archive.sha256sum] = "8f8a340d3ba99bfdef38b653da929652ea6640e27969d29f7ac51fbbe11a4346"
diff --git a/meta/recipes-gnome/gnome/gnome-common_3.14.0.bb b/meta/recipes-gnome/gnome/gnome-common_3.14.0.bb
index 1f9fe8bf5c..80b7033ee1 100644
--- a/meta/recipes-gnome/gnome/gnome-common_3.14.0.bb
+++ b/meta/recipes-gnome/gnome/gnome-common_3.14.0.bb
@@ -8,8 +8,6 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
SECTION = "x11/gnome"
inherit gnomebase allarch
-GNOME_COMPRESS_TYPE = "xz"
-
SRC_URI[archive.md5sum] = "ba58c61d0d81b7c3ff8452c620513a9d"
SRC_URI[archive.sha256sum] = "4c00242f781bb441289f49dd80ed1d895d84de0c94bfc2c6818a104c9e39262c"
diff --git a/meta/recipes-gnome/gnome/gnome-doc-utils_0.20.10.bb b/meta/recipes-gnome/gnome/gnome-doc-utils_0.20.10.bb
index 321eb7f700..78cc005f99 100644
--- a/meta/recipes-gnome/gnome/gnome-doc-utils_0.20.10.bb
+++ b/meta/recipes-gnome/gnome/gnome-doc-utils_0.20.10.bb
@@ -2,8 +2,6 @@ require gnome-doc-utils.inc
LIC_FILES_CHKSUM = "file://COPYING.GPL;md5=eb723b61539feef013de476e68b5c50a \
file://COPYING.LGPL;md5=a6f89e2100d9b6cdffcea4f398e37343"
-GNOME_COMPRESS_TYPE = "xz"
-
SRC_URI += "file://xsltproc_nonet.patch \
file://use-usr-bin-env-for-python-in-xml2po.patch \
file://sysrooted-pkg-config.patch \
diff --git a/meta/recipes-gnome/gnome/gnome-mime-data_2.18.0.bb b/meta/recipes-gnome/gnome/gnome-mime-data_2.18.0.bb
index 65b79f0dc2..a31eb5571a 100644
--- a/meta/recipes-gnome/gnome/gnome-mime-data_2.18.0.bb
+++ b/meta/recipes-gnome/gnome/gnome-mime-data_2.18.0.bb
@@ -13,6 +13,7 @@ SRC_URI += "file://pkgconfig.patch"
SRC_URI[archive.md5sum] = "541858188f80090d12a33b5a7c34d42c"
SRC_URI[archive.sha256sum] = "37196b5b37085bbcd45c338c36e26898fe35dd5975295f69f48028b1e8436fd7"
+GNOME_COMPRESS_TYPE="bz2"
DEPENDS += "shared-mime-info intltool-native"
RDEPENDS_${PN} = "shared-mime-info"
diff --git a/meta/recipes-gnome/gtk-engines/gtk-engines_2.20.2.bb b/meta/recipes-gnome/gtk-engines/gtk-engines_2.20.2.bb
index 036aa27b3a..c30454cab5 100644
--- a/meta/recipes-gnome/gtk-engines/gtk-engines_2.20.2.bb
+++ b/meta/recipes-gnome/gtk-engines/gtk-engines_2.20.2.bb
@@ -32,6 +32,7 @@ CFLAGS_prepend = "-DHAVE_ANIMATION "
RDEPENDS_${PN}-dev = ""
inherit gnomebase
+GNOME_COMPRESS_TYPE="bz2"
python populate_packages_prepend() {
engines_root = os.path.join(d.getVar('libdir', True), "gtk-2.0/2.10.0/engines")
diff --git a/meta/recipes-gnome/json-glib/json-glib_1.0.4.bb b/meta/recipes-gnome/json-glib/json-glib_1.0.4.bb
index 2e6a908a1f..4908ac08a7 100644
--- a/meta/recipes-gnome/json-glib/json-glib_1.0.4.bb
+++ b/meta/recipes-gnome/json-glib/json-glib_1.0.4.bb
@@ -10,8 +10,6 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34"
DEPENDS = "glib-2.0"
-GNOME_COMPRESS_TYPE = "xz"
-
SRC_URI[archive.md5sum] = "3131b0417ecde3da1ae72acceaa375cf"
SRC_URI[archive.sha256sum] = "80f3593cb6bd13f1465828e46a9f740e2e9bd3cd2257889442b3e62bd6de05cd"
diff --git a/meta/recipes-gnome/libglade/libglade_2.6.4.bb b/meta/recipes-gnome/libglade/libglade_2.6.4.bb
index 681b856427..15267cad87 100644
--- a/meta/recipes-gnome/libglade/libglade_2.6.4.bb
+++ b/meta/recipes-gnome/libglade/libglade_2.6.4.bb
@@ -12,6 +12,7 @@ PR = "r5"
DEPENDS = "zlib gdk-pixbuf gtk+"
inherit autotools pkgconfig gnomebase gtk-doc
+GNOME_COMPRESS_TYPE="bz2"
SRC_URI += "file://glade-cruft.patch file://no-xml2.patch file://python_environment.patch"
diff --git a/meta/recipes-gnome/librsvg/librsvg_2.40.10.bb b/meta/recipes-gnome/librsvg/librsvg_2.40.10.bb
index 0ac323e4ea..a8b0e4f9c8 100644
--- a/meta/recipes-gnome/librsvg/librsvg_2.40.10.bb
+++ b/meta/recipes-gnome/librsvg/librsvg_2.40.10.bb
@@ -12,8 +12,6 @@ BBCLASSEXTEND = "native"
inherit autotools pkgconfig gnomebase gtk-doc pixbufcache
-GNOME_COMPRESS_TYPE = "xz"
-
SRC_URI += "file://gtk-option.patch"
SRC_URI[archive.md5sum] = "fadebe2e799ab159169ee3198415ff85"
diff --git a/meta/recipes-graphics/pango/pango_1.36.8.bb b/meta/recipes-graphics/pango/pango_1.36.8.bb
index 4605c768a5..f4e4250409 100644
--- a/meta/recipes-graphics/pango/pango_1.36.8.bb
+++ b/meta/recipes-graphics/pango/pango_1.36.8.bb
@@ -2,8 +2,6 @@ require pango.inc
LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7"
-GNOME_COMPRESS_TYPE="xz"
-
SRC_URI += "file://run-ptest \
file://multilib-fix-clean.patch \
"
diff --git a/meta/recipes-support/atk/atk_2.16.0.bb b/meta/recipes-support/atk/atk_2.16.0.bb
index e29469b50b..0f8f9b5207 100644
--- a/meta/recipes-support/atk/atk_2.16.0.bb
+++ b/meta/recipes-support/atk/atk_2.16.0.bb
@@ -12,8 +12,6 @@ DEPENDS = "glib-2.0"
inherit gnomebase gtk-doc
-GNOME_COMPRESS_TYPE = "xz"
-
SRC_URI[archive.md5sum] = "c7c5002bd6e58b4723a165f1bf312116"
SRC_URI[archive.sha256sum] = "095f986060a6a0b22eb15eef84ae9f14a1cf8082488faa6886d94c37438ae562"
diff --git a/meta/recipes-support/libcroco/libcroco_0.6.8.bb b/meta/recipes-support/libcroco/libcroco_0.6.8.bb
index 88696a4f47..2b1b910631 100644
--- a/meta/recipes-support/libcroco/libcroco_0.6.8.bb
+++ b/meta/recipes-support/libcroco/libcroco_0.6.8.bb
@@ -17,7 +17,5 @@ BINCONFIG = "${bindir}/croco-0.6-config"
inherit autotools pkgconfig gnomebase gtk-doc binconfig-disabled
-GNOME_COMPRESS_TYPE = "xz"
-
SRC_URI[archive.md5sum] = "767e73c4174f75b99695d4530fd9bb80"
SRC_URI[archive.sha256sum] = "ea6e1b858c55219cefd7109756bff5bc1a774ba7a55f7d3ccd734d6b871b8570"
diff --git a/meta/recipes-support/vte/vte_0.28.2.bb b/meta/recipes-support/vte/vte_0.28.2.bb
index 9dab390642..68bc16d8b4 100644
--- a/meta/recipes-support/vte/vte_0.28.2.bb
+++ b/meta/recipes-support/vte/vte_0.28.2.bb
@@ -8,5 +8,5 @@ SRC_URI += "file://obsolete_automake_macros.patch"
CFLAGS += "-D_GNU_SOURCE"
-SRC_URI[archive.md5sum] = "f07a4bf943194f94b7f142db8f7f36dc"
-SRC_URI[archive.sha256sum] = "8d04e202b617373dfb47689e5e628febe2c58840b34cccc4af4feb88c48df903"
+SRC_URI[archive.md5sum] = "497f26e457308649e6ece32b3bb142ff"
+SRC_URI[archive.sha256sum] = "86cf0b81aa023fa93ed415653d51c96767f20b2d7334c893caba71e42654b0ae"