aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2014-01-28 21:27:54 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-01-29 17:37:15 +0000
commit5df33fc62f2d3a5a15dc387ed26cb7da8d9fbbe1 (patch)
tree44c5056d6cfd3ace6123892151d3fd93d72978f1 /meta
parent4f211322eb1179db62c03616b4c113114c612cf8 (diff)
downloadopenembedded-core-contrib-5df33fc62f2d3a5a15dc387ed26cb7da8d9fbbe1.tar.gz
cogl: kms: include necessary header for size_t
Fixes compilation in cases where stddef.h is not already included by EGL headers. Signed-off-by: Andreas Oberritter <obi@opendreambox.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-graphics/cogl/cogl-1.0_1.16.0.bb2
-rw-r--r--meta/recipes-graphics/cogl/cogl-1.16.0/kms-include-stddef.h-before-drm.h.patch33
2 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-graphics/cogl/cogl-1.0_1.16.0.bb b/meta/recipes-graphics/cogl/cogl-1.0_1.16.0.bb
index 5e5c82b501..0ef972622c 100644
--- a/meta/recipes-graphics/cogl/cogl-1.0_1.16.0.bb
+++ b/meta/recipes-graphics/cogl/cogl-1.0_1.16.0.bb
@@ -2,5 +2,7 @@ require cogl-1.0.inc
LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
+SRC_URI += "file://kms-include-stddef.h-before-drm.h.patch"
+
SRC_URI[archive.md5sum] = "611a61bed04354cbfffa3dc27feb6d4f"
SRC_URI[archive.sha256sum] = "75c2c4636a050fda7ee8722ce3d9c618b08799ed92bbb72b4fdff3e73b096094"
diff --git a/meta/recipes-graphics/cogl/cogl-1.16.0/kms-include-stddef.h-before-drm.h.patch b/meta/recipes-graphics/cogl/cogl-1.16.0/kms-include-stddef.h-before-drm.h.patch
new file mode 100644
index 0000000000..7cce279a19
--- /dev/null
+++ b/meta/recipes-graphics/cogl/cogl-1.16.0/kms-include-stddef.h-before-drm.h.patch
@@ -0,0 +1,33 @@
+Upstream-Status: Submitted [cogl@lists.freedesktop.org]
+
+From 5e4f4689308732a0570a1631169247157c59f064 Mon Sep 17 00:00:00 2001
+From: Andreas Oberritter <obi@saftware.de>
+Date: Tue, 28 Jan 2014 18:36:04 +0100
+Subject: [PATCH] kms: include stddef.h before drm.h
+
+Not doing so leads to the following error, if stddef.h is not included
+indirectly through EGL headers:
+
+| libdrm/drm.h:132:2: error: unknown type name 'size_t'
+| size_t name_len; /**< Length of name buffer */
+
+Signed-off-by: Andreas Oberritter <obi@saftware.de>
+---
+ cogl/winsys/cogl-winsys-egl-kms.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/cogl/winsys/cogl-winsys-egl-kms.c b/cogl/winsys/cogl-winsys-egl-kms.c
+index f7c9cfb..144ad9b 100644
+--- a/cogl/winsys/cogl-winsys-egl-kms.c
++++ b/cogl/winsys/cogl-winsys-egl-kms.c
+@@ -40,6 +40,7 @@
+
+ #include <EGL/egl.h>
+ #include <EGL/eglext.h>
++#include <stddef.h>
+ #include <drm.h>
+ #include <xf86drm.h>
+ #include <xf86drmMode.h>
+--
+1.8.3.2
+