aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorZubair Lutfullah Kakakhel <Zubair.Kakakhel@imgtec.com>2016-11-23 13:47:32 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-11-30 15:47:13 +0000
commit5b3cc758ddd8bfe6e52e6287ddf463c080673a7e (patch)
tree95bd2f97345c810ab7e72a34688c5becfb3d89d2 /meta
parentb0975809fe43b7506cc30a60245f5e32b275a3ec (diff)
downloadopenembedded-core-contrib-5b3cc758ddd8bfe6e52e6287ddf463c080673a7e.tar.gz
perf: Add EXTRA_LDFLAGS for MIPS N32
MIPS N32 requires EXTRA_LDFLAGS to link correctly. Signed-off-by: Zubair Lutfullah Kakakhel <Zubair.Kakakhel@imgtec.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-kernel/perf/perf.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index 25ae83cef3..6cdaa68b57 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -80,6 +80,7 @@ EXTRA_OEMAKE = '\
AR="${AR}" \
LD="${LD}" \
EXTRA_CFLAGS="-ldw" \
+ EXTRA_LDFLAGS="${PERF_EXTRA_LDFLAGS}" \
perfexecdir=${libexecdir} \
NO_GTK2=1 ${TUI_DEFINES} NO_DWARF=1 ${LIBUNWIND_DEFINES} \
${SCRIPTING_DEFINES} ${LIBNUMA_DEFINES} \
@@ -98,6 +99,12 @@ EXTRA_OEMAKE += "\
'infodir=${@os.path.relpath(infodir, prefix)}' \
"
+PERF_EXTRA_LDFLAGS = ""
+
+# MIPS N32
+PERF_EXTRA_LDFLAGS_mipsarchn32eb = "-m elf32btsmipn32"
+PERF_EXTRA_LDFLAGS_mipsarchn32el = "-m elf32ltsmipn32"
+
do_compile() {
# Linux kernel build system is expected to do the right thing
unset CFLAGS