aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2016-12-13 20:04:34 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-01-09 13:34:31 +0000
commit94bfdb0accab0a2638e3bea1271cb80596f38e00 (patch)
tree296b86edfeb24f6b62b1be454a4285ca3d8376b7 /meta
parent7bac614503d0d9fda03b087501690e5f8262d966 (diff)
downloadopenembedded-core-contrib-94bfdb0accab0a2638e3bea1271cb80596f38e00.tar.gz
ffmpeg: disable asm for x32
This is the usual way this is handled in desktop distros (see debian, gentoo). I wasn't able to track down a patch to add proper x32 support to ffmpeg. There was, however, a libav patch series which may be worth investigating. Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-multimedia/ffmpeg/ffmpeg_3.2.2.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/ffmpeg/ffmpeg_3.2.2.bb b/meta/recipes-multimedia/ffmpeg/ffmpeg_3.2.2.bb
index 4fac46b117..66718c4b37 100644
--- a/meta/recipes-multimedia/ffmpeg/ffmpeg_3.2.2.bb
+++ b/meta/recipes-multimedia/ffmpeg/ffmpeg_3.2.2.bb
@@ -92,6 +92,8 @@ EXTRA_OECONF = " \
${@bb.utils.contains('AVAILTUNES', 'mips32r2', '', '--disable-mipsdsp --disable-mipsdspr2', d)} \
"
+EXTRA_OECONF_append_linux-gnux32 = " --disable-asm"
+
do_configure() {
${S}/configure ${EXTRA_OECONF}
}