aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-03-13 12:57:37 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-14 14:39:04 +0000
commit13a5c3dac4b5b0ccb4c5dfebf79b468acd8e1983 (patch)
tree06805ef869a068c7f33cf25108170470cbe4a8c1 /meta
parent1bab5be8133f62cdae251e66db6f472c3c37297c (diff)
downloadopenembedded-core-contrib-13a5c3dac4b5b0ccb4c5dfebf79b468acd8e1983.tar.gz
go: add native recipes for 1.8
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/go/go-bootstrap-native_1.4.bb3
-rw-r--r--meta/recipes-devtools/go/go-native.inc16
-rw-r--r--meta/recipes-devtools/go/go-native_1.8.bb (renamed from meta/recipes-devtools/go/go-native_1.4.bb)1
-rw-r--r--meta/recipes-devtools/go/go.inc4
4 files changed, 15 insertions, 9 deletions
diff --git a/meta/recipes-devtools/go/go-bootstrap-native_1.4.bb b/meta/recipes-devtools/go/go-bootstrap-native_1.4.bb
new file mode 100644
index 0000000000..3d4141e879
--- /dev/null
+++ b/meta/recipes-devtools/go/go-bootstrap-native_1.4.bb
@@ -0,0 +1,3 @@
+BOOTSTRAP = "1.4"
+require go-native.inc
+require go-${PV}.inc
diff --git a/meta/recipes-devtools/go/go-native.inc b/meta/recipes-devtools/go/go-native.inc
index 89bc63459d..c1ada5121a 100644
--- a/meta/recipes-devtools/go/go-native.inc
+++ b/meta/recipes-devtools/go/go-native.inc
@@ -1,8 +1,10 @@
inherit native
+BOOTSTRAP ?= ""
export GOOS = "${BUILD_GOOS}"
export GOARCH = "${BUILD_GOARCH}"
-export GOROOT_FINAL = "${STAGING_LIBDIR_NATIVE}/go"
+export GOROOT_FINAL = "${STAGING_LIBDIR_NATIVE}/go${BOOTSTRAP}"
+export GOROOT_BOOTSTRAP = "${STAGING_LIBDIR_NATIVE}/go1.4"
export CGO_ENABLED = "1"
do_configure[noexec] = "1"
@@ -31,18 +33,18 @@ END
}
do_install() {
- install -d ${D}${libdir}/go
- cp -a ${B}/pkg ${D}${libdir}/go/
- install -d ${D}${libdir}/go/src
+ install -d ${D}${libdir}/go${BOOTSTRAP}
+ cp -a ${B}/pkg ${D}${libdir}/go${BOOTSTRAP}/
+ install -d ${D}${libdir}/go${BOOTSTRAP}/src
(cd ${S}/src; for d in *; do \
- [ -d $d ] && cp -a ${S}/src/$d ${D}${libdir}/go/src/; \
+ [ -d $d ] && cp -a ${S}/src/$d ${D}${libdir}/go${BOOTSTRAP}/src/; \
done)
- install -d ${D}${bindir} ${D}${libdir}/go/bin
+ install -d ${D}${bindir} ${D}${libdir}/go${BOOTSTRAP}/bin
for f in ${B}/bin/*
do
base=`basename $f`
- install -m755 $f ${D}${libdir}/go/bin
+ install -m755 $f ${D}${libdir}/go${BOOTSTRAP}/bin
make_wrapper $base $base
done
}
diff --git a/meta/recipes-devtools/go/go-native_1.4.bb b/meta/recipes-devtools/go/go-native_1.8.bb
index bbf3c0dd73..182fca27a0 100644
--- a/meta/recipes-devtools/go/go-native_1.4.bb
+++ b/meta/recipes-devtools/go/go-native_1.8.bb
@@ -1,2 +1,3 @@
require ${PN}.inc
require go-${PV}.inc
+DEPENDS += "go-bootstrap-native"
diff --git a/meta/recipes-devtools/go/go.inc b/meta/recipes-devtools/go/go.inc
index 1c94fc9c34..0b0cbf19ad 100644
--- a/meta/recipes-devtools/go/go.inc
+++ b/meta/recipes-devtools/go/go.inc
@@ -1,6 +1,6 @@
inherit goarch
# libgcc is required for the target specific libraries to build properly
-DEPENDS += " go-native libgcc"
+DEPENDS += "go-bootstrap-native libgcc"
# Prevent runstrip from running because you get errors when the host arch != target arch
INHIBIT_PACKAGE_STRIP = "1"
INHIBIT_SYSROOT_STRIP = "1"
@@ -15,7 +15,7 @@ export GOHOSTARCH = "${BUILD_GOARCH}"
export GOOS = "${TARGET_GOOS}"
export GOARCH = "${TARGET_GOARCH}"
export GOARM = "${TARGET_GOARM}"
-export GOROOT_BOOTSTRAP = "${STAGING_LIBDIR_NATIVE}/go"
+export GOROOT_BOOTSTRAP = "${STAGING_LIBDIR_NATIVE}/go1.4"
export GOROOT_FINAL = "${libdir}/go"
export CGO_ENABLED = "1"
export CC_FOR_TARGET = "${CC}"