aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2016-10-14 08:50:11 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-10-15 09:57:09 +0100
commit68e917aa778742da104c038a6e1ffa789fe95410 (patch)
tree7a77b6b50608f2684451de962a8ba5825c95c5aa /meta
parentefc92a63d40b909864505d3d6d22ce74cd6a847b (diff)
downloadopenembedded-core-contrib-68e917aa778742da104c038a6e1ffa789fe95410.tar.gz
ppp: fix building with linux-4.8
Fix a build error when using the linux-4.8 headers that results in: In file included from pppoe.h:87:0, from plugin.c:29: ../usr/include/netinet/in.h:211:8: note: originally defined here struct in6_addr ^~~~~~~~ In file included from ../usr/include/linux/if_pppol2tp.h:20:0, from ../usr/include/linux/if_pppox.h:26, from plugin.c:52: ../usr/include/linux/in6.h:49:8: error: redefinition of 'struct sockaddr_in6' struct sockaddr_in6 { ^~~~~~~~~~~~ Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-connectivity/ppp/ppp/ppp-fix-building-with-linux-4.8.patch44
-rw-r--r--meta/recipes-connectivity/ppp/ppp_2.4.7.bb1
2 files changed, 45 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/ppp/ppp/ppp-fix-building-with-linux-4.8.patch b/meta/recipes-connectivity/ppp/ppp/ppp-fix-building-with-linux-4.8.patch
new file mode 100644
index 0000000000..f77b0defc5
--- /dev/null
+++ b/meta/recipes-connectivity/ppp/ppp/ppp-fix-building-with-linux-4.8.patch
@@ -0,0 +1,44 @@
+From 3da19af53e2eee2e77b456cfbb9d633b06656d38 Mon Sep 17 00:00:00 2001
+From: Jackie Huang <jackie.huang@windriver.com>
+Date: Thu, 13 Oct 2016 13:41:43 +0800
+Subject: [PATCH] ppp: fix building with linux-4.8
+
+Fix a build error when using the linux-4.8 headers that results in:
+
+In file included from pppoe.h:87:0,
+ from plugin.c:29:
+../usr/include/netinet/in.h:211:8: note: originally defined here
+ struct in6_addr
+ ^~~~~~~~
+In file included from ../usr/include/linux/if_pppol2tp.h:20:0,
+ from ../usr/include/linux/if_pppox.h:26,
+ from plugin.c:52:
+../usr/include/linux/in6.h:49:8: error: redefinition of 'struct sockaddr_in6'
+ struct sockaddr_in6 {
+ ^~~~~~~~~~~~
+
+Upstream-Status: Submitted [1]
+
+[1] https://github.com/paulusmack/ppp/pull/69
+
+Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
+---
+ pppd/plugins/rp-pppoe/pppoe.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/pppd/plugins/rp-pppoe/pppoe.h b/pppd/plugins/rp-pppoe/pppoe.h
+index 9ab2eee..96d2794 100644
+--- a/pppd/plugins/rp-pppoe/pppoe.h
++++ b/pppd/plugins/rp-pppoe/pppoe.h
+@@ -84,7 +84,7 @@ typedef unsigned long UINT32_t;
+ #include <linux/if_ether.h>
+ #endif
+
+-#include <netinet/in.h>
++#include <linux/in.h>
+
+ #ifdef HAVE_NETINET_IF_ETHER_H
+ #include <sys/types.h>
+--
+2.8.3
+
diff --git a/meta/recipes-connectivity/ppp/ppp_2.4.7.bb b/meta/recipes-connectivity/ppp/ppp_2.4.7.bb
index 4437b5c519..56dbd98d24 100644
--- a/meta/recipes-connectivity/ppp/ppp_2.4.7.bb
+++ b/meta/recipes-connectivity/ppp/ppp_2.4.7.bb
@@ -30,6 +30,7 @@ SRC_URI = "http://ppp.samba.org/ftp/ppp/ppp-${PV}.tar.gz \
file://0001-ppp-Fix-compilation-errors-in-Makefile.patch \
file://ppp@.service \
file://fix-CVE-2015-3310.patch \
+ file://ppp-fix-building-with-linux-4.8.patch \
"
SRC_URI_append_libc-musl = "\