aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorAndré Draszik <adraszik@tycoint.com>2017-01-12 10:42:25 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-01-16 18:01:57 +0000
commit7e459843e0371953d3d9d3ad05b019947ed7ca04 (patch)
tree95a1f9c318b5b65523caff2c4ddea848fe29445d /meta
parent5263dd3eac9d9fbdb7ef654d0cd532c192baed16 (diff)
downloadopenembedded-core-contrib-7e459843e0371953d3d9d3ad05b019947ed7ca04.tar.gz
opkg-utils: use D instead of OPKG_OFFLINE_ROOT in postrm
While both result in the same in this case, postrm should really be referring to $D as we do everywhere else. Signed-off-by: André Draszik <adraszik@tycoint.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/opkg-utils/opkg-utils_git.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb b/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb
index 094f4e75de..7b3b86e1dc 100644
--- a/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb
+++ b/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb
@@ -46,8 +46,8 @@ RREPLACES_update-alternatives-opkg = "update-alternatives-cworth"
RCONFLICTS_update-alternatives-opkg = "update-alternatives-cworth"
pkg_postrm_update-alternatives-opkg() {
- rm -rf $OPKG_OFFLINE_ROOT${nonarch_libdir}/opkg/alternatives
- rmdir $OPKG_OFFLINE_ROOT${nonarch_libdir}/opkg || true
+ rm -rf $D${nonarch_libdir}/opkg/alternatives
+ rmdir $D${nonarch_libdir}/opkg || true
}
BBCLASSEXTEND = "native nativesdk"