aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2016-04-22 20:26:26 +0200
committerAndreas Oberritter <obi@opendreambox.org>2017-06-26 22:57:14 +0200
commitd0ace5f753d418b55474ad07c6db59a87cf18ba1 (patch)
treef62d1efa99b557346d01ee3d245b26c7bae05be0 /meta
parent1ee0f07bfcf3783d07f58952e162f0af99eea44b (diff)
downloadopenembedded-core-contrib-d0ace5f753d418b55474ad07c6db59a87cf18ba1.tar.gz
lighttpd: add many packageconfig options
Respect ipv6, largefile and xattr distro features. Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-extended/lighttpd/lighttpd_1.4.39.bb37
1 files changed, 23 insertions, 14 deletions
diff --git a/meta/recipes-extended/lighttpd/lighttpd_1.4.39.bb b/meta/recipes-extended/lighttpd/lighttpd_1.4.39.bb
index 378accbf11..bb29c651ab 100644
--- a/meta/recipes-extended/lighttpd/lighttpd_1.4.39.bb
+++ b/meta/recipes-extended/lighttpd/lighttpd_1.4.39.bb
@@ -6,7 +6,6 @@ LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://COPYING;md5=e4dac5c6ab169aa212feb5028853a579"
SECTION = "net"
-DEPENDS = "zlib libpcre"
RDEPENDS_${PN} += " \
lighttpd-module-access \
lighttpd-module-accesslog \
@@ -26,19 +25,29 @@ SRC_URI = "http://download.lighttpd.net/lighttpd/releases-1.4.x/lighttpd-${PV}.t
SRC_URI[md5sum] = "63c7563be1c7a7a9819a51f07f1af8b2"
SRC_URI[sha256sum] = "7eb9a1853c3d6dd5851682b0733a729ba4158d6bdff80974d5ef5f1f6887365b"
-PACKAGECONFIG ??= "openssl"
-PACKAGECONFIG[openssl] = "--with-openssl, --without-openssl, openssl"
-
-EXTRA_OECONF = " \
- --without-bzip2 \
- --without-ldap \
- --without-lua \
- --without-memcache \
- --with-pcre \
- --without-webdav-props \
- --without-webdav-locks \
- --disable-static \
-"
+PACKAGECONFIG ??= "openssl pcre zlib \
+ ${@base_contains('DISTRO_FEATURES', 'ipv6', 'ipv6', '', d)} \
+ ${@base_contains('DISTRO_FEATURES', 'largefile', 'lfs', '', d)} \
+ ${@base_contains('DISTRO_FEATURES', 'xattr', 'attr', '', d)}"
+PACKAGECONFIG[lfs] = "--enable-lfs,--disable-lfs"
+PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6"
+PACKAGECONFIG[mmap] = "--enable-mmap,--disable-mmap"
+PACKAGECONFIG[libev] = "--with-libev,--without-libev,libev"
+PACKAGECONFIG[mysql] = "--with-mysql,--without-mysql,mariadb"
+PACKAGECONFIG[ldap] = "--with-ldap,--without-ldap,openldap"
+PACKAGECONFIG[attr] = "--with-attr,--without-attr,attr"
+PACKAGECONFIG[valgrind] = "--with-valgrind,--without-valgrind,valgrind"
+PACKAGECONFIG[openssl] = "--with-openssl,--without-openssl,openssl"
+PACKAGECONFIG[kerberos5] = "--with-kerberos5,--without-kerberos5"
+PACKAGECONFIG[pcre] = "--with-pcre,--without-pcre,libpcre"
+PACKAGECONFIG[zlib] = "--with-zlib,--without-zlib,zlib"
+PACKAGECONFIG[bzip2] = "--with-bzip2,--without-bzip2,bzip2"
+PACKAGECONFIG[fam] = "--with-fam,--without-fam,gamin"
+PACKAGECONFIG[webdav-props] = "--with-webdav-props,--without-webdav-props,libxml2 sqlite3"
+PACKAGECONFIG[webdav-locks] = "--with-webdav-locks,--without-webdav-locks,util-linux"
+PACKAGECONFIG[gdbm] = "--with-gdbm,--without-gdbm,gdbm"
+PACKAGECONFIG[memcache] = "--with-memcache,--without-memcache,memcached"
+PACKAGECONFIG[lua] = "--with-lua,--without-lua,lua5.1"
inherit autotools pkgconfig update-rc.d gettext systemd