aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2014-09-21 20:44:29 +0200
committerAndreas Oberritter <obi@opendreambox.org>2015-02-23 17:15:53 +0100
commit87d244c925c37d3408874649a2092989c95acc24 (patch)
treec50e4f865dfa6033a9a3ee4ceb18f79df0e0b69b /meta
parentccb54cd09197e340c3772269e9552ca8506ca101 (diff)
downloadopenembedded-core-contrib-87d244c925c37d3408874649a2092989c95acc24.tar.gz
nfs-utils: change file ownership for statd
Otherwise, rpc.statd complains about "Running as root. chown /var/lib/nfs/statd to choose different user" when started by systemd. While at it, update --with-statduser argument to match the actual username for statd. Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-connectivity/nfs-utils/nfs-utils_1.3.0.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta/recipes-connectivity/nfs-utils/nfs-utils_1.3.0.bb b/meta/recipes-connectivity/nfs-utils/nfs-utils_1.3.0.bb
index 391aeac776..c3c6d0b7b4 100644
--- a/meta/recipes-connectivity/nfs-utils/nfs-utils_1.3.0.bb
+++ b/meta/recipes-connectivity/nfs-utils/nfs-utils_1.3.0.bb
@@ -55,7 +55,7 @@ SYSTEMD_SERVICE_${PN} = "nfs-server.service nfs-mountd.service"
SYSTEMD_SERVICE_${PN}-client = "nfs-statd.service"
# --enable-uuid is need for cross-compiling
-EXTRA_OECONF = "--with-statduser=nobody \
+EXTRA_OECONF = "--with-statduser=rpcuser \
--enable-mountconfig \
--enable-libmount-mount \
--disable-nfsv41 \
@@ -98,8 +98,9 @@ do_compile_prepend() {
}
do_install_append () {
+ chown -R rpcuser:rpcuser ${D}${localstatedir}/lib/nfs/statd
+
install -d ${D}${sysconfdir}/init.d
- install -d ${D}${localstatedir}/lib/nfs/statd
install -m 0755 ${WORKDIR}/nfsserver ${D}${sysconfdir}/init.d/nfsserver
install -m 0755 ${WORKDIR}/nfscommon ${D}${sysconfdir}/init.d/nfscommon