aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-01-12 19:08:51 -0800
committerAndreas Oberritter <obi@opendreambox.org>2015-04-22 10:03:27 +0200
commit4cba213a8dfc0857be7c5449ec978e5e61eaf71f (patch)
tree8a0fabcd9906be5266aa1e3635b8fa77872766b4 /meta
parent82b87742c3505ffd20934e9ca16198b1c246a85e (diff)
downloadopenembedded-core-contrib-4cba213a8dfc0857be7c5449ec978e5e61eaf71f.tar.gz
connman: fix B != S
And bump the PR to avoid: configure: error: source directory already configured; run "make distclean" there first Signed-off-by: Robert Yang <liezhi.yang@windriver.com> (cherry picked from commit 38aa1ef57392fcb726fcdd0b708b9d76f0279c77) Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-connectivity/connman/connman.inc12
-rw-r--r--meta/recipes-connectivity/connman/connman_1.26.bb2
2 files changed, 8 insertions, 6 deletions
diff --git a/meta/recipes-connectivity/connman/connman.inc b/meta/recipes-connectivity/connman/connman.inc
index cea68d8c22..7f03872cdc 100644
--- a/meta/recipes-connectivity/connman/connman.inc
+++ b/meta/recipes-connectivity/connman/connman.inc
@@ -62,15 +62,15 @@ SYSTEMD_WIRED_SETUP = "ExecStartPre=-${libdir}/connman/wired-setup"
inherit autotools pkgconfig systemd update-rc.d
do_configure_append () {
- sed -i "s#ExecStart=#${SYSTEMD_WIRED_SETUP}\nExecStart=#" ${S}/src/connman.service
+ sed -i "s#ExecStart=#${SYSTEMD_WIRED_SETUP}\nExecStart=#" ${B}/src/connman.service
}
# This allows *everyone* to access ConnMan over DBus, without any access
# control. Really the at_console flag should work, which would mean that
# both this and the xuser patch can be dropped.
do_compile_append() {
- sed -i -e s:deny:allow:g src/connman-dbus.conf
- sed -i -e s:deny:allow:g vpn/vpn-dbus.conf
+ sed -i -e s:deny:allow:g ${S}/src/connman-dbus.conf
+ sed -i -e s:deny:allow:g ${S}/vpn/vpn-dbus.conf
}
do_install_append() {
@@ -81,9 +81,9 @@ do_install_append() {
fi
install -d ${D}${bindir}
- install -m 0755 ${S}/tools/*-test ${D}${bindir}
- if [ -e ${S}/tools/wispr ]; then
- install -m 0755 ${S}/tools/wispr ${D}${bindir}
+ install -m 0755 ${B}/tools/*-test ${D}${bindir}
+ if [ -e ${B}/tools/wispr ]; then
+ install -m 0755 ${B}/tools/wispr ${D}${bindir}
fi
install -m 0755 ${B}/client/connmanctl ${D}${bindir}
diff --git a/meta/recipes-connectivity/connman/connman_1.26.bb b/meta/recipes-connectivity/connman/connman_1.26.bb
index b93f1cd6c3..7c0c4f7863 100644
--- a/meta/recipes-connectivity/connman/connman_1.26.bb
+++ b/meta/recipes-connectivity/connman/connman_1.26.bb
@@ -9,3 +9,5 @@ SRC_URI[md5sum] = "ba05b110b7c81e5fa14e8b402ef37a9e"
SRC_URI[sha256sum] = "7184e4b6d954449ee00a30e188924b3e37a20ad2fd9a0b76a2bdd82c863dcf8a"
RRECOMMENDS_${PN} = "connman-conf"
+
+PR = "r1"