aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorMartin Borg <martin.borg@enea.com>2016-02-25 16:08:04 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-28 11:32:38 +0000
commite9db0ae11d95f3c375b27d5c10606efd8b568fbf (patch)
tree6b056d15dedf96b617c9cd3bd4fa115a8f651436 /meta
parent11b0e7e1cb29fd1fbe06bdb5606a55b92ecdcc89 (diff)
downloadopenembedded-core-contrib-e9db0ae11d95f3c375b27d5c10606efd8b568fbf.tar.gz
automake: set test-driver path relative to top_builddir
automake offers auxiliary tools and is capable to install and prepare the setup for those. test-driver, a log driver used by parallel testsuite harness in ptests, is one of those tools. By default it looks that automake prepare environment for testing relative $top_srcdir. But in Yocto following changed: - build folder was separated - $top_srcdir is not anymore defined as relative path, now can be relative or absolute So now in Yocto the Makefile from src/tests contains absolute path of $top_srcdir for test-driver which is an unexisting path at runtime. We need to have relative path for test-driver in Makefile to work on target. $top_builddir can guarantee this path. Originally submitted by Adrian Calianu <adrian.calianu@enea.com> Signed-off-by: Martin Borg <martin.borg@enea.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/automake/automake/new_rt_path_for_test-driver.patch36
-rw-r--r--meta/recipes-devtools/automake/automake_1.15.bb3
2 files changed, 38 insertions, 1 deletions
diff --git a/meta/recipes-devtools/automake/automake/new_rt_path_for_test-driver.patch b/meta/recipes-devtools/automake/automake/new_rt_path_for_test-driver.patch
new file mode 100644
index 0000000000..2c6594f523
--- /dev/null
+++ b/meta/recipes-devtools/automake/automake/new_rt_path_for_test-driver.patch
@@ -0,0 +1,36 @@
+Set relative to top_builddir path in Makefile to access test-driver
+
+Signed-off-by: Adrian Calianu <adrian.calianu@enea.com>
+Upstream-Status: Pending
+Bug-Report: http://debbugs.gnu.org/cgi/bugreport.cgi?bug=19042
+
+--- a/bin/automake.in
++++ b/bin/automake.in
+@@ -272,6 +272,9 @@
+ # $AM_CONFIG_AUX_DIR is prefixed with $(top_srcdir), so it can be used
+ # in Makefiles.
+ my $am_config_aux_dir = '';
++# Directory used at runtime like running test-driver that should not
++# depend on $(top_srcdir)
++my $am_config_rt_aux_dir = '';
+
+ # Directory to search for AC_LIBSOURCE files, as set by AC_CONFIG_LIBOBJ_DIR
+ # in configure.ac.
+@@ -4700,7 +4703,7 @@
+ {
+ require_conf_file ("parallel-tests", FOREIGN, 'test-driver');
+ define_variable ("${pfx}LOG_DRIVER",
+- "\$(SHELL) $am_config_aux_dir/test-driver",
++ "\$(SHELL) $am_config_rt_aux_dir/test-driver",
+ INTERNAL);
+ }
+ my $driver = '$(' . $pfx . 'LOG_DRIVER)';
+@@ -7284,6 +7287,10 @@
+ $am_config_aux_dir =
+ '$(top_srcdir)' . ($config_aux_dir eq '.' ? "" : "/$config_aux_dir");
+ $am_config_aux_dir =~ s,/*$,,;
++
++ $am_config_rt_aux_dir =
++ '$(top_builddir)' . ($config_aux_dir eq '.' ? "" : "/$config_aux_dir");
++ $am_config_rt_aux_dir =~ s,/*$,,;
+ }
diff --git a/meta/recipes-devtools/automake/automake_1.15.bb b/meta/recipes-devtools/automake/automake_1.15.bb
index e3cb85b41a..85494b4af0 100644
--- a/meta/recipes-devtools/automake/automake_1.15.bb
+++ b/meta/recipes-devtools/automake/automake_1.15.bb
@@ -21,7 +21,8 @@ RDEPENDS_${PN}_class-native = "autoconf-native hostperl-runtime-native"
SRC_URI += " file://python-libdir.patch \
file://py-compile-compile-only-optimized-byte-code.patch \
file://buildtest.patch \
- file://performance.patch"
+ file://performance.patch \
+ file://new_rt_path_for_test-driver.patch"
SRC_URI[md5sum] = "716946a105ca228ab545fc37a70df3a3"
SRC_URI[sha256sum] = "7946e945a96e28152ba5a6beb0625ca715c6e32ac55f2e353ef54def0c8ed924"