aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorIoan-Adrian Ratiu <adrian.ratiu@ni.com>2016-02-04 14:32:53 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-28 11:32:37 +0000
commitc8be8890e0a9c9d5f1532c4ee4fe9a346ed3ca5b (patch)
tree38c7141e4d0f4738577b5f260db2bcf2321645f8 /meta
parentef82fb5aff4ca3204b40cdf6a074d9711e543af2 (diff)
downloadopenembedded-core-contrib-c8be8890e0a9c9d5f1532c4ee4fe9a346ed3ca5b.tar.gz
apr-util: add ldap crypto and sqlite3 to PACKAGECONFIG
Enable apr-util's cryptographic routines so that the apache2 package can encrypt session data. Also add sqlite3 and ldap modules, disabled by default. Signed-off-by: Ioan-Adrian Ratiu <adrian.ratiu@ni.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-support/apr/apr-util_1.5.4.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-support/apr/apr-util_1.5.4.bb b/meta/recipes-support/apr/apr-util_1.5.4.bb
index 381daaddf3..28962bd0ef 100644
--- a/meta/recipes-support/apr/apr-util_1.5.4.bb
+++ b/meta/recipes-support/apr/apr-util_1.5.4.bb
@@ -24,7 +24,6 @@ EXTRA_OECONF = "--with-apr=${STAGING_BINDIR_CROSS}/apr-1-config \
--with-dbm=gdbm \
--with-gdbm=${STAGING_DIR_HOST}${prefix} \
--without-sqlite2 \
- --without-sqlite3 \
--with-expat=${STAGING_DIR_HOST}${prefix}"
@@ -66,6 +65,11 @@ do_install_append_class-target() {
-e 's,APU_BUILD_DIR=.*,APR_BUILD_DIR=,g' ${D}${bindir}/apu-1-config
}
+PACKAGECONFIG ??= "crypto"
+PACKAGECONFIG[ldap] = "--with-ldap,--without-ldap,openldap"
+PACKAGECONFIG[crypto] = "--with-openssl=${STAGING_DIR_HOST}${prefix} --with-crypto,--without-crypto,openssl"
+PACKAGECONFIG[sqlite3] = "--with-sqlite3=${STAGING_DIR_HOST}${prefix},--without-sqlite3,sqlite3"
+
#files ${libdir}/apr-util-1/*.so are not symlinks but loadable modules thus they are packaged in ${PN}
FILES_${PN} += "${libdir}/apr-util-1/apr*${SOLIBS} ${libdir}/apr-util-1/apr*${SOLIBSDEV}"
FILES_${PN}-dev += "${libdir}/aprutil.exp ${libdir}/apr-util-1/*.la"