aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorDengke Du <dengke.du@windriver.com>2016-02-23 02:59:04 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-28 11:32:35 +0000
commit74b5088f1cc1708db43c33ac2dc7f01f4a4db9c1 (patch)
tree8c421579111298724fb7d61b56a844f68c84b15c /meta
parent09ac424c6a04ac46a822168341a55293ba43dc27 (diff)
downloadopenembedded-core-contrib-74b5088f1cc1708db43c33ac2dc7f01f4a4db9c1.tar.gz
strace: fix ptest execution
When run the strace ptest on the target, the test files located in the "/usr/lib/strace/ptest/tests", but the run-test script use the path "srcdir = ../../strace-*/tests"to find the necessary files, so it can't find the necessary files, it fails. So change the variable srcdir, replace the strace-* to ptest when do the do_install_ptest() function using the following: sed -i -e '/^src/s/strace.*[1-9]/ptest/' ${D}/${PTEST_PATH}/${TESTDIR}/Makefile Signed-off-by: Dengke Du <dengke.du@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/strace/strace_4.11.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-devtools/strace/strace_4.11.bb b/meta/recipes-devtools/strace/strace_4.11.bb
index 3e542ca049..51ec5b5427 100644
--- a/meta/recipes-devtools/strace/strace_4.11.bb
+++ b/meta/recipes-devtools/strace/strace_4.11.bb
@@ -41,6 +41,7 @@ do_compile_ptest() {
do_install_ptest() {
oe_runmake -C ${TESTDIR} install-ptest BUILDDIR=${B} DESTDIR=${D}${PTEST_PATH} TESTDIR=${TESTDIR}
+ sed -i -e '/^src/s/strace.*[1-9]/ptest/' ${D}/${PTEST_PATH}/${TESTDIR}/Makefile
}
BBCLASSEXTEND = "native"