summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2020-02-03 12:32:25 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-02-04 15:56:24 +0000
commit9cc4dc9cc951157e6e374192c88369432ae5cff1 (patch)
tree640a60fc81cdfcfa1e0e852efe97962d0ef085f2 /meta
parent46884b1443d92cea877201296bd480b6cbd71cca (diff)
downloadopenembedded-core-contrib-9cc4dc9cc951157e6e374192c88369432ae5cff1.tar.gz
piglit: don't stage the test suite
The Piglit test suite is approximately 2GB and because it's installed into $libdir is added to the sysroot archive. Nothing links against Piglit so there's no reason for this, so remove $libdir from Piglit's sysroot. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-graphics/piglit/piglit_git.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-graphics/piglit/piglit_git.bb b/meta/recipes-graphics/piglit/piglit_git.bb
index d0d8331697..58d10d6b9b 100644
--- a/meta/recipes-graphics/piglit/piglit_git.bb
+++ b/meta/recipes-graphics/piglit/piglit_git.bb
@@ -44,6 +44,7 @@ do_configure_prepend() {
fi
}
+# Forcibly strip because Piglit is *huge*
OECMAKE_TARGET_INSTALL = "install/strip"
RDEPENDS_${PN} = "waffle waffle-bin python3 python3-mako python3-json \
@@ -55,5 +56,9 @@ RDEPENDS_${PN} = "waffle waffle-bin python3 python3-mako python3-json \
INSANE_SKIP_${PN} += "dev-so already-stripped"
+# As nothing builds against Piglit we don't need to have anything in the
+# sysroot, especially when this is ~2GB of test suite
+SYSROOT_DIRS_remove = "${libdir}"
+
# Can't be built with ccache
CCACHE_DISABLE = "1"