aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-03-16 20:33:57 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-21 22:43:02 +0000
commit74f4dcfd447fb528ab230e67e3f7ab37e8f93898 (patch)
treec05311b5c587e80234145fbbb83ab830a24ab3db /meta
parent61135e4134b7e0b42b57a87a9a30c32002cb1067 (diff)
downloadopenembedded-core-contrib-74f4dcfd447fb528ab230e67e3f7ab37e8f93898.tar.gz
ltp: Fix __sighandler_t for mips
mips definition of kernel_sigaction was added later and the patch did not apply to mips part which ended in ltp failing to compile on mips parts In file included from rt_sigaction01.c:42:0: ../../../../include/lapi/rt_sigaction.h:39:2: error: unknown type name '__sighandler_t' __sighandler_t k_sa_handler; ^~~~~~~~~~~~~~ Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-extended/ltp/ltp/0028-rt_sigaction.h-Use-sighandler_t-instead-of-__sighand.patch31
1 files changed, 17 insertions, 14 deletions
diff --git a/meta/recipes-extended/ltp/ltp/0028-rt_sigaction.h-Use-sighandler_t-instead-of-__sighand.patch b/meta/recipes-extended/ltp/ltp/0028-rt_sigaction.h-Use-sighandler_t-instead-of-__sighand.patch
index fc82ff9239..b26aa133e9 100644
--- a/meta/recipes-extended/ltp/ltp/0028-rt_sigaction.h-Use-sighandler_t-instead-of-__sighand.patch
+++ b/meta/recipes-extended/ltp/ltp/0028-rt_sigaction.h-Use-sighandler_t-instead-of-__sighand.patch
@@ -13,23 +13,29 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
testcases/kernel/syscalls/rt_sigsuspend/Makefile | 3 +++
2 files changed, 4 insertions(+), 1 deletion(-)
-diff --git a/include/lapi/rt_sigaction.h b/include/lapi/rt_sigaction.h
-index 3a5a763..870918c 100644
---- a/include/lapi/rt_sigaction.h
-+++ b/include/lapi/rt_sigaction.h
-@@ -34,7 +34,7 @@
- #define INVAL_SA_PTR ((void *)-1)
-
+Index: git/include/lapi/rt_sigaction.h
+===================================================================
+--- git.orig/include/lapi/rt_sigaction.h
++++ git/include/lapi/rt_sigaction.h
+@@ -36,12 +36,12 @@
+ #if defined(__mips__)
+ struct kernel_sigaction {
+ unsigned int sa_flags;
+- __sighandler_t k_sa_handler;
++ sighandler_t k_sa_handler;
+ sigset_t sa_mask;
+ };
+ #else
struct kernel_sigaction {
- __sighandler_t k_sa_handler;
+ sighandler_t k_sa_handler;
unsigned long sa_flags;
void (*sa_restorer) (void);
sigset_t sa_mask;
-diff --git a/testcases/kernel/syscalls/rt_sigsuspend/Makefile b/testcases/kernel/syscalls/rt_sigsuspend/Makefile
-index 37bc3a9..2ca7f7c 100644
---- a/testcases/kernel/syscalls/rt_sigsuspend/Makefile
-+++ b/testcases/kernel/syscalls/rt_sigsuspend/Makefile
+Index: git/testcases/kernel/syscalls/rt_sigsuspend/Makefile
+===================================================================
+--- git.orig/testcases/kernel/syscalls/rt_sigsuspend/Makefile
++++ git/testcases/kernel/syscalls/rt_sigsuspend/Makefile
@@ -19,4 +19,7 @@
top_srcdir ?= ../../../..
@@ -38,6 +44,3 @@ index 37bc3a9..2ca7f7c 100644
+CFLAGS += -D_GNU_SOURCE
+
include $(top_srcdir)/include/mk/generic_leaf_target.mk
---
-2.7.0
-