summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-10-12 14:43:55 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-10-14 09:20:56 +0100
commitbe2592f5c755589c05125c02f732f981ccacf4b3 (patch)
treeaa675e4fab2903509fc6424e523d1b722140fdcf /meta
parent4837c3b0ad46e08c5063e842d0f53f05b31c4873 (diff)
downloadopenembedded-core-contrib-be2592f5c755589c05125c02f732f981ccacf4b3.tar.gz
python3: add ptest runner
Copy the Python 2 run-ptest script to execute the Python 3 test suite. (From OE-Core rev: d371ff04628bdf7bac66341aeb9a66d145f66416) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/python/python3/run-ptest3
-rw-r--r--meta/recipes-devtools/python/python3_3.5.6.bb5
2 files changed, 7 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python3/run-ptest b/meta/recipes-devtools/python/python3/run-ptest
new file mode 100644
index 0000000000..3863c6d314
--- /dev/null
+++ b/meta/recipes-devtools/python/python3/run-ptest
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+python3 -m test -v | sed -e '/\.\.\. ok/ s/^/PASS: /g' -e '/\.\.\. [ERROR|FAIL]/ s/^/FAIL: /g' -e '/\.\.\. skipped/ s/^/SKIP: /g' -e 's/ \.\.\. ok//g' -e 's/ \.\.\. ERROR//g' -e 's/ \.\.\. FAIL//g' -e 's/ \.\.\. skipped//g'
diff --git a/meta/recipes-devtools/python/python3_3.5.6.bb b/meta/recipes-devtools/python/python3_3.5.6.bb
index c481aadb36..372f27b15d 100644
--- a/meta/recipes-devtools/python/python3_3.5.6.bb
+++ b/meta/recipes-devtools/python/python3_3.5.6.bb
@@ -44,9 +44,10 @@ SRC_URI += "\
file://0003-bpo-32947-Fixes-for-TLS-1.3-and-OpenSSL-1.1.1-GH-876.patch \
file://0004-bpo-33570-TLS-1.3-ciphers-for-OpenSSL-1.1.1-GH-6976.patch \
file://0005-bpo-30714-ALPN-changes-for-OpenSSL-1.1.0f-2305.patch \
+ file://run-ptest \
"
-inherit multilib_header python3native update-alternatives qemu
+inherit multilib_header python3native update-alternatives qemu ptest
MULTILIB_SUFFIX = "${@d.getVar('base_libdir',1).split('/')[-1]}"
@@ -242,6 +243,8 @@ FILES_${PN}-misc = "${libdir}/python${PYTHON_MAJMIN}"
PACKAGES += "${PN}-man"
FILES_${PN}-man = "${datadir}/man"
+RDEPENDS_${PN}-ptest = "${PN}-modules ${PN}-tests unzip bzip2"
+
BBCLASSEXTEND = "nativesdk"
RPROVIDES_${PN} += "${PN}-modules"