summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2021-03-08 16:46:50 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-03-08 18:12:38 +0000
commit5663c387f4a7491db07008fed65246929aa3a94e (patch)
tree2332c33dbac0a38418adcc94fba7e65d770233e4 /meta
parent89c87a0ffff3dd25c124afdf04362da22c84d5e9 (diff)
downloadopenembedded-core-contrib-5663c387f4a7491db07008fed65246929aa3a94e.tar.gz
build-appliance-image: Drop kernel module handling
kernel-devsrc is a dependency of the image so we no longer need the symlink creation code or the module-base inherit/dependency as it is included in that recipe. The KERNEL_VERSION usage was broken anyway as the module usage would have needed a: do_image[depends] += "build-appliance-image:do_configure" which wasn't present so it was indeterminate if KERNEL_VERSION was set correctly. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-core/images/build-appliance-image_15.0.0.bb8
1 files changed, 1 insertions, 7 deletions
diff --git a/meta/recipes-core/images/build-appliance-image_15.0.0.bb b/meta/recipes-core/images/build-appliance-image_15.0.0.bb
index 705ff63cf7..2bb8d6da56 100644
--- a/meta/recipes-core/images/build-appliance-image_15.0.0.bb
+++ b/meta/recipes-core/images/build-appliance-image_15.0.0.bb
@@ -22,7 +22,7 @@ APPEND += "rootfstype=ext4 quiet"
DEPENDS = "zip-native python3-pip-native"
IMAGE_FSTYPES = "wic.vmdk wic.vhd wic.vhdx"
-inherit core-image module-base setuptools3
+inherit core-image setuptools3
SRCREV ?= "e56305dd709ae2af2da7a7599984b3ad18c4970f"
SRC_URI = "git://git.yoctoproject.org/poky \
@@ -61,12 +61,6 @@ fakeroot do_populate_poky_src () {
# Place the README_VirtualBox_Toaster file in builders home folder.
cp ${WORKDIR}/README_VirtualBox_Toaster.txt ${IMAGE_ROOTFS}/home/builder/
- # Create a symlink, needed for out-of-tree kernel modules build
- if [ ! -e ${IMAGE_ROOTFS}/lib/modules/${KERNEL_VERSION}/build ]; then
- rm -f ${IMAGE_ROOTFS}/lib/modules/${KERNEL_VERSION}/build
- lnr ${IMAGE_ROOTFS}${KERNEL_SRC_PATH} ${IMAGE_ROOTFS}/lib/modules/${KERNEL_VERSION}/build
- fi
-
echo "INHERIT += \"rm_work\"" >> ${IMAGE_ROOTFS}/home/builder/poky/build/conf/auto.conf
echo "export LC_ALL=en_US.utf8" >> ${IMAGE_ROOTFS}/home/builder/.bashrc