aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorJens Rehsack <sno@netbsd.org>2018-08-27 15:20:15 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-08-28 10:27:15 +0100
commita5439ff9627d309f6980947f5ee573d85e672228 (patch)
tree4d999640c9a52752379b44ffffc44fe30841a5ec /meta
parent104d07e57488f4a414fb5e1f60d0c8b0c02d6b4d (diff)
downloadopenembedded-core-contrib-a5439ff9627d309f6980947f5ee573d85e672228.tar.gz
cpan.bbclass: make RPATH fix more general
Extract a general version of RPATH fix for libxml-parser-perl_2.44.bb from 292471701 libxml-parser-perl: fix "...contains bad RPATH" into cpan.bbclass to catch most errors reported by Khem Raj via http://errors.yoctoproject.org/Errors/Build/66538/ Genrally, Perl 5 toolchain deals with cross-compile sysroots as if a dependency is installed at an exostic place on a server. This issue needs to be addressed wider into the community. Signed-off-by: Jens Rehsack <sno@netbsd.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/classes/cpan.bbclass10
-rw-r--r--meta/recipes-devtools/perl/libxml-parser-perl_2.44.bb7
2 files changed, 10 insertions, 7 deletions
diff --git a/meta/classes/cpan.bbclass b/meta/classes/cpan.bbclass
index 926c6358a6..a5bc301898 100644
--- a/meta/classes/cpan.bbclass
+++ b/meta/classes/cpan.bbclass
@@ -40,6 +40,16 @@ cpan_do_configure () {
fi
}
+do_configure_append_class-target() {
+ find . -name Makefile | xargs sed -E -i \
+ -e 's:LD_RUN_PATH ?= ?"?[^"]*"?::g'
+}
+
+do_configure_append_class-nativesdk() {
+ find . -name Makefile | xargs sed -E -i \
+ -e 's:LD_RUN_PATH ?= ?"?[^"]*"?::g'
+}
+
cpan_do_compile () {
oe_runmake PASTHRU_INC="${CFLAGS}" LD="${CCLD}"
}
diff --git a/meta/recipes-devtools/perl/libxml-parser-perl_2.44.bb b/meta/recipes-devtools/perl/libxml-parser-perl_2.44.bb
index 194ed6ac48..95af4d1de6 100644
--- a/meta/recipes-devtools/perl/libxml-parser-perl_2.44.bb
+++ b/meta/recipes-devtools/perl/libxml-parser-perl_2.44.bb
@@ -21,13 +21,6 @@ inherit cpan ptest-perl
do_configure_append_class-target() {
sed -E \
-e 's:-L${STAGING_LIBDIR}::g' -e 's:-I${STAGING_INCDIR}::g' \
- -e 's:LD_RUN_PATH ?= ?"?[^"]*"?::g' \
- -i Makefile Expat/Makefile
-}
-
-do_configure_append_class-nativesdk() {
- sed -E \
- -e 's:LD_RUN_PATH ?= ?"?[^"]*"?::g' \
-i Makefile Expat/Makefile
}