aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2016-08-22 17:06:03 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-08-31 17:53:29 +0100
commit54737d28ce0ead702ceebf00a4d4b74d1ee40211 (patch)
tree12e819b602fef35aaf7bdb60323022b9e44dbeb9 /meta
parentb85f3bcca00c3bbe6e7097c182be20492ab78cb8 (diff)
downloadopenembedded-core-contrib-54737d28ce0ead702ceebf00a4d4b74d1ee40211.tar.gz
nspr: control ipv6 support based on DISTRO_FEATURES
Add PACKAGECONFIG for ipv6 and control it based on DISTRO_FEATURES. Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-support/nspr/nspr_4.12.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-support/nspr/nspr_4.12.bb b/meta/recipes-support/nspr/nspr_4.12.bb
index 168341bc05..fa6d52357d 100644
--- a/meta/recipes-support/nspr/nspr_4.12.bb
+++ b/meta/recipes-support/nspr/nspr_4.12.bb
@@ -147,6 +147,9 @@ TESTS = " \
inherit autotools
+PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', 'ipv6', '', d)}"
+PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
+
do_compile_prepend() {
oe_runmake CROSS_COMPILE=1 CFLAGS="-DXP_UNIX" LDFLAGS="" CC=gcc -C config export
}