aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorJoshua Lock <josh@linux.intel.com>2010-03-24 17:29:02 +0000
committerJoshua Lock <josh@linux.intel.com>2010-03-26 10:29:18 +0000
commit555f60faa0bcaa0d3faab7ccf12e8c663f9ba51c (patch)
tree1c9445dfe693bc04fec31f66a0b2cf7f9f6fca7e /meta
parent9b3a51fbd8ad4f9a27f561b7ee65d3babfdc6a9e (diff)
downloadopenembedded-core-contrib-555f60faa0bcaa0d3faab7ccf12e8c663f9ba51c.tar.gz
yum: Fix installation of python modules
Signed-off-by: Joshua Lock <josh@linux.intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/packages/yum/files/paths2.patch30
-rw-r--r--meta/packages/yum/yum_3.2.27.bb2
2 files changed, 17 insertions, 15 deletions
diff --git a/meta/packages/yum/files/paths2.patch b/meta/packages/yum/files/paths2.patch
index 08c9c8312e..8fe6d0c983 100644
--- a/meta/packages/yum/files/paths2.patch
+++ b/meta/packages/yum/files/paths2.patch
@@ -3,31 +3,33 @@
yum/Makefile | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
---- yum-3.2.18.orig/rpmUtils/Makefile
-+++ yum-3.2.18/rpmUtils/Makefile
-@@ -1,10 +1,10 @@
- PYTHON=python
+Index: yum-3.2.27/rpmUtils/Makefile
+===================================================================
+--- yum-3.2.27.orig/rpmUtils/Makefile 2010-03-24 17:26:39.759798777 +0000
++++ yum-3.2.27/rpmUtils/Makefile 2010-03-24 17:26:54.835863845 +0000
+@@ -2,8 +2,8 @@
PACKAGE = $(shell basename `pwd`)
PYFILES = $(wildcard *.py)
PYVER := $(shell $(PYTHON) -c 'import sys; print "%.3s" %(sys.version)')
-PYSYSDIR := $(shell $(PYTHON) -c 'import sys; print sys.prefix')
-+PYSYSDIR = /usr
- PYLIBDIR = $(PYSYSDIR)/lib/python$(PYVER)
+-PYLIBDIR = $(PYSYSDIR)/lib/python$(PYVER)
++PYSYSDIR = $(libdir)
++PYLIBDIR = $(PYSYSDIR)/python$(PYVER)
PKGDIR = $(PYLIBDIR)/site-packages/$(PACKAGE)
all:
- echo "Nothing to do"
---- yum-3.2.18.orig/yum/Makefile
-+++ yum-3.2.18/yum/Makefile
-@@ -1,10 +1,10 @@
- PYTHON=python
+Index: yum-3.2.27/yum/Makefile
+===================================================================
+--- yum-3.2.27.orig/yum/Makefile 2010-03-24 17:26:39.759798777 +0000
++++ yum-3.2.27/yum/Makefile 2010-03-24 17:26:43.726773783 +0000
+@@ -2,8 +2,8 @@
PACKAGE = $(shell basename `pwd`)
PYFILES = $(wildcard *.py)
PYVER := $(shell $(PYTHON) -c 'import sys; print "%.3s" %(sys.version)')
-PYSYSDIR := $(shell $(PYTHON) -c 'import sys; print sys.prefix')
-+PYSYSDIR = /usr
- PYLIBDIR = $(PYSYSDIR)/lib/python$(PYVER)
+-PYLIBDIR = $(PYSYSDIR)/lib/python$(PYVER)
++PYSYSDIR = $(libdir)
++PYLIBDIR = $(PYSYSDIR)/python$(PYVER)
PKGDIR = $(PYLIBDIR)/site-packages/$(PACKAGE)
all:
- echo "Nothing to do"
diff --git a/meta/packages/yum/yum_3.2.27.bb b/meta/packages/yum/yum_3.2.27.bb
index e51aacd562..75669af448 100644
--- a/meta/packages/yum/yum_3.2.27.bb
+++ b/meta/packages/yum/yum_3.2.27.bb
@@ -1,5 +1,5 @@
HOMEPAGE = "http://linux.duke.edu/projects/yum/"
-PR = "r7"
+PR = "r8"
SRC_URI = "http://linux.duke.edu/projects/yum/download/3.2/yum-${PV}.tar.gz \
file://paths.patch;patch=1 \