summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2019-04-23 06:12:16 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-05-13 20:50:00 +0100
commit754baa7ccc8afad300f1a391469b6b428e37f096 (patch)
treefd76bff714413c76b631af5ac4920c036c2cdaac /meta
parentf93f026212ebc28fce66682cdb995e061586df45 (diff)
downloadopenembedded-core-contrib-754baa7ccc8afad300f1a391469b6b428e37f096.tar.gz
webkitgtk: fix compile error for arm64
It removes function JSC::AssemblerBuffer::data() for ARM64 in commit https://trac.webkit.org/changeset/236589/webkit. But it is required by Cortex A53 from https://trac.webkit.org/changeset/175514/webkit and fails to compile for arm64: | .../tmp/work/aarch64-poky-linux/webkitgtk/2.24.0-r0/webkitgtk-2.24.0/Source/JavaScriptCore/assembler/ARM64Assembler.h:3769:100: error: 'class JSC::AssemblerBuffer' has no member named 'data' | if (UNLIKELY((*reinterpret_cast_ptr<int32_t*>(reinterpret_cast_ptr<char*>(m_buffer.data()) + m_buffer.codeSize() - sizeof(int32_t)) & 0x0a000000) == 0x08000000)) Not set WTF_CPU_ARM64_CORTEXA53 for arm64 to fix the failure. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-sato/webkit/webkitgtk_2.24.0.bb2
1 files changed, 0 insertions, 2 deletions
diff --git a/meta/recipes-sato/webkit/webkitgtk_2.24.0.bb b/meta/recipes-sato/webkit/webkitgtk_2.24.0.bb
index 808c92a378..96ac5ac18f 100644
--- a/meta/recipes-sato/webkit/webkitgtk_2.24.0.bb
+++ b/meta/recipes-sato/webkit/webkitgtk_2.24.0.bb
@@ -97,8 +97,6 @@ EXTRA_OECMAKE_append_aarch64 = " -DUSE_LD_GOLD=OFF "
EXTRA_OECMAKE_append_mipsarch = " -DUSE_LD_GOLD=OFF "
EXTRA_OECMAKE_append_powerpc = " -DUSE_LD_GOLD=OFF "
-EXTRA_OECMAKE_append_aarch64 = " -DWTF_CPU_ARM64_CORTEXA53=ON"
-
# JIT not supported on MIPS either
EXTRA_OECMAKE_append_mipsarch = " -DENABLE_JIT=OFF "