aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-09-03 14:45:39 +0100
committerSaul Wold <sgw@linux.intel.com>2012-09-03 22:52:55 -0700
commit3063126e2c8ec72e900a48f7048aaf9662606792 (patch)
tree1535805e4a122156ac3416699deeac7cf28adbd9 /meta
parente6755e3351ccf1116c06b9608728630505908ce4 (diff)
downloadopenembedded-core-contrib-3063126e2c8ec72e900a48f7048aaf9662606792.tar.gz
oprofileui-server: move initscript from qemu-config
The qemu-config initscript was only starting oprofile-server, so move it to the oprofileui-server recipe. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-bsp/qemu-config/qemu-config.bb11
-rwxr-xr-xmeta/recipes-kernel/oprofile/oprofileui-server/init (renamed from meta/recipes-bsp/qemu-config/qemu-config/qemu-autostart)8
-rw-r--r--meta/recipes-kernel/oprofile/oprofileui-server_git.bb13
3 files changed, 18 insertions, 14 deletions
diff --git a/meta/recipes-bsp/qemu-config/qemu-config.bb b/meta/recipes-bsp/qemu-config/qemu-config.bb
index 6775af34e3..4179fc0492 100644
--- a/meta/recipes-bsp/qemu-config/qemu-config.bb
+++ b/meta/recipes-bsp/qemu-config/qemu-config.bb
@@ -11,8 +11,7 @@ PR = "r25"
SRC_URI = "file://distcc.sh \
file://exports \
- file://shutdown.desktop \
- file://qemu-autostart"
+ file://shutdown.desktop"
S = "${WORKDIR}"
@@ -24,9 +23,6 @@ do_install() {
install -d ${D}${datadir}/applications
install -m 0644 shutdown.desktop ${D}${datadir}/applications/
-
- install -d ${D}${sysconfdir}/init.d
- install qemu-autostart ${D}${sysconfdir}/init.d/
}
pkg_postinst_${PN} () {
@@ -36,7 +32,4 @@ pkg_postinst_${PN} () {
RDEPENDS_${PN} = "distcc packagegroup-core-nfs-server oprofileui-server bash"
-inherit update-rc.d allarch
-
-INITSCRIPT_NAME = "qemu-autostart"
-INITSCRIPT_PARAMS = "start 999 5 2 . stop 20 0 1 6 ."
+inherit allarch
diff --git a/meta/recipes-bsp/qemu-config/qemu-config/qemu-autostart b/meta/recipes-kernel/oprofile/oprofileui-server/init
index db2668eb4e..2544ea4ac0 100755
--- a/meta/recipes-bsp/qemu-config/qemu-config/qemu-autostart
+++ b/meta/recipes-kernel/oprofile/oprofileui-server/init
@@ -1,11 +1,11 @@
#!/bin/sh
### BEGIN INIT INFO
-# Provides: hddtemp
+# Provides: oprofile-server
# Required-Start: $network
# Required-Stop: $network
# Default-Start: 2 3 4 5
# Default-Stop: 0 1 6
-# Short-Description: OProfile server
+# Short-Description: OProfileUI server
# Description:
### END INIT INFO
@@ -13,13 +13,13 @@
case "$1" in
start)
- echo "Starting automatic qemu services"
+ echo "Starting OProfileUI server"
. /etc/profile
/usr/bin/oprofile-server &
;;
stop)
- echo "Stopping qemu services"
+ echo "Stopping OProfileUI server"
killproc oprofile-server
;;
diff --git a/meta/recipes-kernel/oprofile/oprofileui-server_git.bb b/meta/recipes-kernel/oprofile/oprofileui-server_git.bb
index b9f6a811e5..e75923f2a3 100644
--- a/meta/recipes-kernel/oprofile/oprofileui-server_git.bb
+++ b/meta/recipes-kernel/oprofile/oprofileui-server_git.bb
@@ -6,8 +6,19 @@ PR = "r0"
S = "${WORKDIR}/git"
-SRC_URI = "git://git.yoctoproject.org/oprofileui;protocol=git"
+SRC_URI = "git://git.yoctoproject.org/oprofileui;protocol=git \
+ file://init"
EXTRA_OECONF += "--disable-client --enable-server"
RDEPENDS_${PN} = "oprofile"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/oprofileui-server
+}
+
+INITSCRIPT_NAME = "oprofileui-server"
+INITSCRIPT_PARAMS = "start 999 5 2 . stop 20 0 1 6 ."
+
+inherit update-rc.d