aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2015-12-24 17:47:53 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-07 13:40:20 +0000
commitf54e53cb8819c5f53604a7c231782d9473f9b036 (patch)
treeaabef5731aa65eaa826d9922a97195569e136f7a /meta
parent6d111c8290035de45c4a4221b9ef6fd7021108b0 (diff)
downloadopenembedded-core-contrib-f54e53cb8819c5f53604a7c231782d9473f9b036.tar.gz
bash: fix buildpaths qa check error
Script bashbug and Makefile for ptest contain build related paths which cause fail to pass buldpaths QA check. Remove such paths from these 2 files. (From OE-Core rev: b600adb4297798f108cb38d8ad7581bc517ae56b) Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-extended/bash/bash.inc6
1 files changed, 4 insertions, 2 deletions
diff --git a/meta/recipes-extended/bash/bash.inc b/meta/recipes-extended/bash/bash.inc
index 85639d3bb9..93ca00b25c 100644
--- a/meta/recipes-extended/bash/bash.inc
+++ b/meta/recipes-extended/bash/bash.inc
@@ -45,13 +45,15 @@ do_install_append () {
}
do_install_append_class-target () {
# Clean host path in bashbug
- sed -i -e "s,${STAGING_DIR_TARGET},,g" ${D}${bindir}/bashbug
+ sed -i -e "s,--sysroot=${STAGING_DIR_TARGET},,g" \
+ -e "s,-I${WORKDIR}/\S* ,,g" ${D}${bindir}/bashbug
}
do_install_ptest () {
make INSTALL_TEST_DIR=${D}${PTEST_PATH}/tests install-test
cp ${B}/Makefile ${D}${PTEST_PATH}
- sed -i 's/^Makefile/_Makefile/' ${D}${PTEST_PATH}/Makefile
+ sed -i -e 's/^Makefile/_Makefile/' -e "s,--sysroot=${STAGING_DIR_TARGET},,g" \
+ -e "s,${S},,g" -e "s,${B},,g" -e "s,${STAGING_DIR_NATIVE},,g" ${D}${PTEST_PATH}/Makefile
}
pkg_postinst_${PN} () {