aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorPatrick Ohly <patrick.ohly@intel.com>2015-01-23 06:48:18 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-01-28 21:23:02 +0000
commit822df6d23c9c24e131c38fda9f0012c47ad7af46 (patch)
treef8609aedf44543be8167635da46c1ff4a07bc015 /meta
parentd1ff61a16a3fcfdd7cf882bc89fb1d164cb1603a (diff)
downloadopenembedded-core-contrib-822df6d23c9c24e131c38fda9f0012c47ad7af46.tar.gz
binconfig-disabled: install config scripts in sysroot
The purpose of binconfig-disabled is to manipulate config scripts such that using them causes errors. But that only works when the modified config script really gets installed in the sysroot. That is not the case with the staging code in binconfig.bbclass. Only patched config files get staged. For that reason it seemed more appropriate to change binconfig-disabled instead of binconfig. The reason for the change was the observation that the swig recipe needs pcre-config installed on the host system. Staging pcre-config removes that host dependency. swig did not actually end up *using* the pcre-config from the host, because later during do_compile the patched configure.ac is used to re-generate configure. Signed-off-by: Patrick Ohly <patrick.ohly@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/classes/binconfig-disabled.bbclass10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta/classes/binconfig-disabled.bbclass b/meta/classes/binconfig-disabled.bbclass
index 4c42ae22e4..0acc9648b0 100644
--- a/meta/classes/binconfig-disabled.bbclass
+++ b/meta/classes/binconfig-disabled.bbclass
@@ -16,3 +16,13 @@ do_install_append () {
echo "exit 1" >> ${D}$x
done
}
+
+SYSROOT_PREPROCESS_FUNCS += "binconfig_disabled_sysroot_preprocess"
+
+binconfig_disabled_sysroot_preprocess () {
+ for x in ${BINCONFIG}; do
+ configname=`basename $x`
+ install -d ${SYSROOT_DESTDIR}${bindir_crossscripts}
+ install ${D}$x ${SYSROOT_DESTDIR}${bindir_crossscripts}
+ done
+}