summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2019-05-15 18:40:04 +0000
committerArmin Kuster <akuster808@gmail.com>2019-06-01 14:48:32 -0700
commit5d35f27f8db102f2cb63c86c163c9952352dbb1d (patch)
tree1e9e1bc0c9589bb47ea4ed96b8f8fc52bbd86bf2 /meta
parentd6d588f560d644546d01d52935dfe7a27ba64859 (diff)
downloadopenembedded-core-contrib-5d35f27f8db102f2cb63c86c163c9952352dbb1d.tar.gz
perf: make sure that the tools/include/uapi/asm-generic directory exists
* before trying to copy unistd.h into it * older kernels don't have uapi in tools/include and do_configure fails with: DEBUG: Executing shell function do_configure cp: cannot create regular file '.../perf/1.0-r9/perf-1.0/tools/include/uapi/asm-generic/unistd.h': No such file or directory WARNING: exit code 1 from a shell command. * tools/include/uapi was added in kernel 4.8 with https://github.com/torvalds/linux/commit/c4b6014e8bb0c8d47fe5c71ebc604f31091e5d3f tools: Add copy of perf_event.h to tools/include/linux/ Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-kernel/perf/perf.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index 546076f84b..4e603f1a32 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -238,7 +238,7 @@ do_configure_prepend () {
# unistd.h can be out of sync between libc-headers and the captured version in the perf source
# so we copy it from the sysroot unistd.h to the perf unistd.h
- cp ${STAGING_INCDIR}/asm-generic/unistd.h ${S}/tools/include/uapi/asm-generic/unistd.h
+ install -D -m0644 ${STAGING_INCDIR}/asm-generic/unistd.h ${S}/tools/include/uapi/asm-generic/unistd.h
}
python do_package_prepend() {