aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorArmin Kuster <akuster@mvista.com>2016-07-09 11:56:49 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-07-27 08:29:30 +0100
commit32fd9fed93b896ee50006a95cc9d0209b85268cd (patch)
treefb85d69f59bde54ccc1e1d8e66535d0e902533ef /meta
parent0c82ab38064baaf25169d75ddccaa3926b62c7e3 (diff)
downloadopenembedded-core-contrib-32fd9fed93b896ee50006a95cc9d0209b85268cd.tar.gz
glibc: Security fix for CVE-2016-4429
Signed-off-by: Armin Kuster <akuster@mvista.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-core/glibc/glibc/CVE-2016-4429.patch89
-rw-r--r--meta/recipes-core/glibc/glibc_2.22.bb1
2 files changed, 90 insertions, 0 deletions
diff --git a/meta/recipes-core/glibc/glibc/CVE-2016-4429.patch b/meta/recipes-core/glibc/glibc/CVE-2016-4429.patch
new file mode 100644
index 0000000000..24aa9a41a1
--- /dev/null
+++ b/meta/recipes-core/glibc/glibc/CVE-2016-4429.patch
@@ -0,0 +1,89 @@
+From bc779a1a5b3035133024b21e2f339fe4219fb11c Mon Sep 17 00:00:00 2001
+From: Florian Weimer <fweimer@redhat.com>
+Date: Mon, 23 May 2016 20:18:34 +0200
+Subject: [PATCH] CVE-2016-4429: sunrpc: Do not use alloca in clntudp_call [BZ
+ #20112]
+
+The call is technically in a loop, and under certain circumstances
+(which are quite difficult to reproduce in a test case), alloca
+can be invoked repeatedly during a single call to clntudp_call.
+As a result, the available stack space can be exhausted (even
+though individual alloca sizes are bounded implicitly by what
+can fit into a UDP packet, as a side effect of the earlier
+successful send operation).
+
+Upstream-Status: Backport
+CVE: CVE-2016-4429
+Signed-off-by: Armin Kuster <akuster@mvista.com>
+
+---
+ ChangeLog | 7 +++++++
+ NEWS | 4 ++++
+ sunrpc/clnt_udp.c | 10 +++++++++-
+ 3 files changed, 20 insertions(+), 1 deletion(-)
+
+Index: git/ChangeLog
+===================================================================
+--- git.orig/ChangeLog
++++ git/ChangeLog
+@@ -1,3 +1,10 @@
++2016-05-23 Florian Weimer <fweimer@redhat.com>
++
++ CVE-2016-4429
++ [BZ #20112]
++ * sunrpc/clnt_udp.c (clntudp_call): Use malloc/free for the error
++ payload.
++
+ 2016-04-29 Florian Weimer <fweimer@redhat.com>
+
+ [BZ #20010]
+Index: git/NEWS
+===================================================================
+--- git.orig/NEWS
++++ git/NEWS
+@@ -5,6 +5,11 @@ See the end for copying conditions.
+ Security related changes:
+
+ [Add security related changes here]
++
++* The Sun RPC UDP client could exhaust all available stack space when
++ flooded with crafted ICMP and UDP messages. Reported by Aldy Hernandez'
++ alloca plugin for GCC. (CVE-2016-4429)
++
+ * Previously, getaddrinfo copied large amounts of address data to the stack,
+ even after the fix for CVE-2013-4458 has been applied, potentially
+ resulting in a stack overflow. getaddrinfo now uses a heap allocation
+Index: git/sunrpc/clnt_udp.c
+===================================================================
+--- git.orig/sunrpc/clnt_udp.c
++++ git/sunrpc/clnt_udp.c
+@@ -420,9 +420,15 @@ send_again:
+ struct sock_extended_err *e;
+ struct sockaddr_in err_addr;
+ struct iovec iov;
+- char *cbuf = (char *) alloca (outlen + 256);
++ char *cbuf = malloc (outlen + 256);
+ int ret;
+
++ if (cbuf == NULL)
++ {
++ cu->cu_error.re_errno = errno;
++ return (cu->cu_error.re_status = RPC_CANTRECV);
++ }
++
+ iov.iov_base = cbuf + 256;
+ iov.iov_len = outlen;
+ msg.msg_name = (void *) &err_addr;
+@@ -447,10 +453,12 @@ send_again:
+ cmsg = CMSG_NXTHDR (&msg, cmsg))
+ if (cmsg->cmsg_level == SOL_IP && cmsg->cmsg_type == IP_RECVERR)
+ {
++ free (cbuf);
+ e = (struct sock_extended_err *) CMSG_DATA(cmsg);
+ cu->cu_error.re_errno = e->ee_errno;
+ return (cu->cu_error.re_status = RPC_CANTRECV);
+ }
++ free (cbuf);
+ }
+ #endif
+ do
diff --git a/meta/recipes-core/glibc/glibc_2.22.bb b/meta/recipes-core/glibc/glibc_2.22.bb
index 4cf2ed7dbf..a423d3dbb7 100644
--- a/meta/recipes-core/glibc/glibc_2.22.bb
+++ b/meta/recipes-core/glibc/glibc_2.22.bb
@@ -49,6 +49,7 @@ SRC_URI = "${GLIBC_GIT_URI};branch=${SRCBRANCH};name=glibc \
file://CVE-2015-7547.patch \
file://CVE-2015-8778.patch \
file://CVE-2016-3706.patch \
+ file://CVE-2016-4429.patch \
"
SRC_URI += "\