aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorJoão Henrique Ferreira de Freitas <joaohf@gmail.com>2014-07-18 00:09:25 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-07-19 00:08:58 +0100
commitf07c17dcee56c8c020b965bf62d81209a6d2eca4 (patch)
tree32bb7d2634d5892eadbef23a63b335c4b8a91d9f /meta
parentd984fcf740e0a9661c459d435dc11c07d6ed3c62 (diff)
downloadopenembedded-core-contrib-f07c17dcee56c8c020b965bf62d81209a6d2eca4.tar.gz
python-distribute: add nativesdk to BBCLASSEXTEND
Without this, python tools that need python-distribute doesn't install in SDK generated by OE. (From OE-Core rev: 778a00c3dd656bbfac03274b5f60788518f7b964) Signed-off-by: João Henrique Ferreira de Freitas <joaohf@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/python/python-distribute_0.6.32.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python-distribute_0.6.32.bb b/meta/recipes-devtools/python/python-distribute_0.6.32.bb
index 58bb8b4545..70001457e0 100644
--- a/meta/recipes-devtools/python/python-distribute_0.6.32.bb
+++ b/meta/recipes-devtools/python/python-distribute_0.6.32.bb
@@ -39,6 +39,12 @@ do_install_append() {
echo "./${SRCNAME}-${PV}-py${PYTHON_BASEVERSION}.egg" > ${D}${PYTHON_SITEPACKAGES_DIR}/setuptools.pth
}
+do_install_append_class-nativesdk() {
+ sed -i -e '1s|^#!.*|#!/usr/bin/env python|' ${D}${PYTHON_SITEPACKAGES_DIR}/distribute-${PV}-py${PYTHON_BASEVERSION}.egg/setuptools/tests/test_resources.py
+ sed -i -e '1s|^#!.*|#!/usr/bin/env python|' ${D}${bindir}/easy_install
+ sed -i -e '1s|^#!.*|#!/usr/bin/env python|' ${D}${bindir}/easy_install-${PYTHON_BASEVERSION}
+}
+
RDEPENDS_${PN} = "\
python-distutils \
python-compression \
@@ -46,4 +52,4 @@ RDEPENDS_${PN} = "\
RPROVIDES_${PN} += "python-setuptools"
-BBCLASSEXTEND = "native"
+BBCLASSEXTEND = "native nativesdk"