aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2014-09-30 21:08:17 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-09-30 21:10:27 +0100
commit2c1c70eef4df66a0208f60ee51bd36d8f794144e (patch)
tree34090b0e5d56df610149f4af690fba3aef5ff96c /meta
parent472efca12108d26201d2236ff436a08845313f48 (diff)
downloadopenembedded-core-contrib-2c1c70eef4df66a0208f60ee51bd36d8f794144e.tar.gz
perl: Improve sysroot regexp
When rebuilding libxml-parser-perl with a change to libdir, you see strange build failures due to MakerMake looking in strange library paths. The error is obtuse and hard to track down. I'm therefore proposing we change the regexp once and for all to resolve the issue. Currently it only does a replacement once, this change ensures it always gets set the correct value upon rebuilds. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/perl/perl_5.20.0.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.20.0.bb b/meta/recipes-devtools/perl/perl_5.20.0.bb
index e984c906de..e594c5c7cf 100644
--- a/meta/recipes-devtools/perl/perl_5.20.0.bb
+++ b/meta/recipes-devtools/perl/perl_5.20.0.bb
@@ -189,7 +189,7 @@ do_compile() {
sed -i -e "s|\([ \"\']\+\)/usr/include|\1${STAGING_INCDIR}|g" ext/Errno/Errno_pm.PL
sed -i -e "s|\([ \"\']\+\)/usr/include|\1${STAGING_INCDIR}|g" cpan/Compress-Raw-Zlib/config.in
sed -i -e 's|/usr/lib|""|g' cpan/Compress-Raw-Zlib/config.in
- sed -i -e 's|SYSROOTLIB|${STAGING_LIBDIR}|g' cpan/ExtUtils-MakeMaker/lib/ExtUtils/Liblist/Kid.pm
+ sed -i -e 's|(@libpath, ".*"|(@libpath, "${STAGING_LIBDIR}"|g' cpan/ExtUtils-MakeMaker/lib/ExtUtils/Liblist/Kid.pm
cd Cross
oe_runmake perl LD="${CCLD}"