aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorLianhao Lu <lianhao.lu@intel.com>2012-03-23 12:31:51 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-03-23 12:02:18 +0000
commitc69268305e6f814800b64f3a4be724c40b41108c (patch)
treeb6d0c7ceede8dc240060ce89ecd570a6f0664dfb /meta
parentc09a2058f6b2f24ab2ae9c5ea357111dd82af39e (diff)
downloadopenembedded-core-contrib-c69268305e6f814800b64f3a4be724c40b41108c.tar.gz
nativesdk/misc: set PKGSUFFIX for correct variable name expansion.
Set PKGSUFFIX in nativesdk.bbclass for correct variable name expansion. This would fix bunch of "not shipped" packaging warnings in "-nativesdk" recipes. And also bumping the corresponding PR. Signed-off-by: Lianhao Lu <lianhao.lu@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/classes/nativesdk.bbclass2
-rw-r--r--meta/recipes-core/eglibc/eglibc-locale.inc2
-rw-r--r--meta/recipes-core/eglibc/eglibc_2.13.bb2
-rw-r--r--meta/recipes-core/eglibc/eglibc_2.15.bb2
-rw-r--r--meta/recipes-devtools/opkg/opkg.inc2
-rw-r--r--meta/recipes-multimedia/alsa/alsa-lib_1.0.25.bb2
-rw-r--r--meta/recipes-support/sqlite/sqlite3_3.7.10.bb2
7 files changed, 8 insertions, 6 deletions
diff --git a/meta/classes/nativesdk.bbclass b/meta/classes/nativesdk.bbclass
index ceec53e86d..97c460c289 100644
--- a/meta/classes/nativesdk.bbclass
+++ b/meta/classes/nativesdk.bbclass
@@ -56,6 +56,8 @@ baselib = "lib"
export PKG_CONFIG_DIR = "${STAGING_DIR_HOST}${libdir}/pkgconfig"
export PKG_CONFIG_SYSROOT_DIR = "${STAGING_DIR_HOST}"
+PKGSUFFIX = "-nativesdk"
+
python nativesdk_virtclass_handler () {
if not isinstance(e, bb.event.RecipePreFinalise):
return
diff --git a/meta/recipes-core/eglibc/eglibc-locale.inc b/meta/recipes-core/eglibc/eglibc-locale.inc
index 2e9b4d4059..9d5434f653 100644
--- a/meta/recipes-core/eglibc/eglibc-locale.inc
+++ b/meta/recipes-core/eglibc/eglibc-locale.inc
@@ -26,7 +26,7 @@ BINARY_LOCALE_ARCHES ?= "arm.* i[3-6]86 x86_64 powerpc mips"
# set "0" for qemu emulation of native localedef for locale generation
LOCALE_GENERATION_WITH_CROSS-LOCALEDEF = "1"
-PR = "r19"
+PR = "r20"
PKGSUFFIX = ""
PKGSUFFIX_virtclass-nativesdk = "-nativesdk"
diff --git a/meta/recipes-core/eglibc/eglibc_2.13.bb b/meta/recipes-core/eglibc/eglibc_2.13.bb
index a4f59b62ce..e02c80fe44 100644
--- a/meta/recipes-core/eglibc/eglibc_2.13.bb
+++ b/meta/recipes-core/eglibc/eglibc_2.13.bb
@@ -3,7 +3,7 @@ require eglibc.inc
SRCREV = "15508"
DEPENDS += "gperf-native"
-PR = "r21"
+PR = "r22"
PR_append = "+svnr${SRCPV}"
EGLIBC_BRANCH="eglibc-2_13"
diff --git a/meta/recipes-core/eglibc/eglibc_2.15.bb b/meta/recipes-core/eglibc/eglibc_2.15.bb
index 3820f5aa09..644d904214 100644
--- a/meta/recipes-core/eglibc/eglibc_2.15.bb
+++ b/meta/recipes-core/eglibc/eglibc_2.15.bb
@@ -3,7 +3,7 @@ require eglibc.inc
SRCREV = "16540"
DEPENDS += "gperf-native"
-PR = "r1"
+PR = "r2"
PR_append = "+svnr${SRCPV}"
EGLIBC_BRANCH="eglibc-2_15"
diff --git a/meta/recipes-devtools/opkg/opkg.inc b/meta/recipes-devtools/opkg/opkg.inc
index 689bd4ad10..14083d0cd1 100644
--- a/meta/recipes-devtools/opkg/opkg.inc
+++ b/meta/recipes-devtools/opkg/opkg.inc
@@ -11,7 +11,7 @@ DEPENDS_virtclass-native = "curl-native"
DEPENDS_virtclass-nativesdk = "curl-nativesdk"
PE = "1"
-INC_PR = "r8"
+INC_PR = "r9"
FILESDIR = "${@os.path.dirname(d.getVar('FILE',1))}/opkg"
diff --git a/meta/recipes-multimedia/alsa/alsa-lib_1.0.25.bb b/meta/recipes-multimedia/alsa/alsa-lib_1.0.25.bb
index 90b0cba037..b128d77f45 100644
--- a/meta/recipes-multimedia/alsa/alsa-lib_1.0.25.bb
+++ b/meta/recipes-multimedia/alsa/alsa-lib_1.0.25.bb
@@ -14,7 +14,7 @@ BBCLASSEXTEND = "native nativesdk"
#FIXME: remove the following
ARM_INSTRUCTION_SET = "arm"
-PR = "r0"
+PR = "r1"
SRC_URI = "ftp://ftp.alsa-project.org/pub/lib/alsa-lib-${PV}.tar.bz2 \
file://fix-tstamp-declaration.patch"
diff --git a/meta/recipes-support/sqlite/sqlite3_3.7.10.bb b/meta/recipes-support/sqlite/sqlite3_3.7.10.bb
index 25e2b243ad..ec6ded6d30 100644
--- a/meta/recipes-support/sqlite/sqlite3_3.7.10.bb
+++ b/meta/recipes-support/sqlite/sqlite3_3.7.10.bb
@@ -1,6 +1,6 @@
require sqlite3.inc
-PR = "r1"
+PR = "r2"
LIC_FILES_CHKSUM = "file://sqlite3.h;endline=11;md5=65f0a57ca6928710b418c094b3570bb0"