aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRoy Li <rongqing.li@windriver.com>2014-10-22 16:35:43 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-11-04 10:19:53 +0000
commit9f2398a0ff42389052155d971f136a37c5dc80da (patch)
tree6477227c6e0a3b363a4a5892d6d43c4e3702c348 /meta
parente0dc0432b13f38d16f642bdadf8ebc78b7a74806 (diff)
downloadopenembedded-core-contrib-9f2398a0ff42389052155d971f136a37c5dc80da.tar.gz
python3: do not replace ccache in the middle of a path
Python recipe did a sed s/ccache/$(CCACHE) on the Makefile, which replaces all "ccache" including ones that consist of a full path. This leads to build error when building in a project path with "ccache" in its name. Fix it by only replacing "ccache " with "$(CCACHE) ". Same fix on python 2.xx is: 1181112cf65bc[python: do not replace ccache in the ] Signed-off-by: Roy Li <rongqing.li@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/python/python3_3.3.3.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python3_3.3.3.bb b/meta/recipes-devtools/python/python3_3.3.3.bb
index a1cb12078f..4497e02586 100644
--- a/meta/recipes-devtools/python/python3_3.3.3.bb
+++ b/meta/recipes-devtools/python/python3_3.3.3.bb
@@ -84,7 +84,7 @@ do_compile() {
cd -
# remove hardcoded ccache, see http://bugs.openembedded.net/show_bug.cgi?id=4144
- sed -i -e s,ccache,'$(CCACHE)', Makefile
+ sed -i -e s,ccache\ ,'$(CCACHE) ', Makefile
# remove any bogus LD_LIBRARY_PATH
sed -i -e s,RUNSHARED=.*,RUNSHARED=, Makefile