aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-07-25 22:09:13 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-07-26 15:22:47 +0100
commit54a54778fad39931ac7d43daaf37ce7c1946a29b (patch)
tree418abbd873cfebe61dfff30dd1f22fc5b7f959e3 /meta
parent5c09cbe3bf456e968fc853827698eb18b62e8348 (diff)
downloadopenembedded-core-contrib-54a54778fad39931ac7d43daaf37ce7c1946a29b.tar.gz
meta: Rename SITEINFO_ENDIANESS to SITEINFO_ENDIANNESS
There is this discrepency in spelling. Lets fix it in core. There are lot of layers using SITEINFO_ENDIANNESS This was shielded since meta-oe had its own copy of siteinfo class. But that class has now been deleted in favor of oe-core Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/classes/siteinfo.bbclass4
-rw-r--r--meta/conf/machine/include/tune-xscale.inc4
-rw-r--r--meta/recipes-connectivity/openssl/openssl.inc2
-rw-r--r--meta/recipes-connectivity/openssl/openssl_0.9.8r.bb2
-rw-r--r--meta/recipes-devtools/perl/perl_5.12.3.bb4
-rw-r--r--meta/recipes-qt/qt4/qt4-embedded.inc2
-rw-r--r--meta/recipes-qt/qt4/qt4-x11-free.inc2
-rw-r--r--meta/recipes-qt/qt4/qt4_arch.inc4
8 files changed, 12 insertions, 12 deletions
diff --git a/meta/classes/siteinfo.bbclass b/meta/classes/siteinfo.bbclass
index c5308b3d26..f3c24e88f3 100644
--- a/meta/classes/siteinfo.bbclass
+++ b/meta/classes/siteinfo.bbclass
@@ -86,9 +86,9 @@ def siteinfo_data(d):
python () {
sitedata = set(siteinfo_data(d))
if "endian-little" in sitedata:
- d.setVar("SITEINFO_ENDIANESS", "le")
+ d.setVar("SITEINFO_ENDIANNESS", "le")
elif "endian-big" in sitedata:
- d.setVar("SITEINFO_ENDIANESS", "be")
+ d.setVar("SITEINFO_ENDIANNESS", "be")
else:
bb.error("Unable to determine endianness for architecture '%s'" %
d.getVar("HOST_ARCH", True))
diff --git a/meta/conf/machine/include/tune-xscale.inc b/meta/conf/machine/include/tune-xscale.inc
index 71dba5bb1e..7fabb4618e 100644
--- a/meta/conf/machine/include/tune-xscale.inc
+++ b/meta/conf/machine/include/tune-xscale.inc
@@ -4,8 +4,8 @@ INHERIT += "siteinfo"
TUNE_CCARGS = "-march=armv5te -mtune=xscale"
TARGET_CC_KERNEL_ARCH = "-march=armv5te -mtune=xscale"
-TUNE_PKGARCH = "${@['armv5teb', 'armv5te'][bb.data.getVar('SITEINFO_ENDIANESS', d, 1) == 'le']}"
-PACKAGE_EXTRA_ARCHS = "${@['armeb armv4b armv4tb armv5teb', 'arm armv4 armv4t armv5te'][bb.data.getVar('SITEINFO_ENDIANESS', d, 1) == 'le']}"
+TUNE_PKGARCH = "${@['armv5teb', 'armv5te'][bb.data.getVar('SITEINFO_ENDIANNESS', d, 1) == 'le']}"
+PACKAGE_EXTRA_ARCHS = "${@['armeb armv4b armv4tb armv5teb', 'arm armv4 armv4t armv5te'][bb.data.getVar('SITEINFO_ENDIANNESS', d, 1) == 'le']}"
# webkit-gtk has alignment issues with double instructions on armv5 so
# disable them here
diff --git a/meta/recipes-connectivity/openssl/openssl.inc b/meta/recipes-connectivity/openssl/openssl.inc
index b134ad005a..88d5081495 100644
--- a/meta/recipes-connectivity/openssl/openssl.inc
+++ b/meta/recipes-connectivity/openssl/openssl.inc
@@ -16,7 +16,7 @@ SRC_URI = "http://www.openssl.org/source/openssl-${PV}.tar.gz \
S = "${WORKDIR}/openssl-${PV}"
AR_append = " r"
-CFLAG = "${@base_conditional('SITEINFO_ENDIANESS', 'le', '-DL_ENDIAN', '-DB_ENDIAN', d)} \
+CFLAG = "${@base_conditional('SITEINFO_ENDIANNESS', 'le', '-DL_ENDIAN', '-DB_ENDIAN', d)} \
-DTERMIO ${FULL_OPTIMIZATION} -Wall"
# Avoid binaries being marked as requiring an executable stack (which causes
diff --git a/meta/recipes-connectivity/openssl/openssl_0.9.8r.bb b/meta/recipes-connectivity/openssl/openssl_0.9.8r.bb
index 344747f9a3..54bdcc2f14 100644
--- a/meta/recipes-connectivity/openssl/openssl_0.9.8r.bb
+++ b/meta/recipes-connectivity/openssl/openssl_0.9.8r.bb
@@ -1,6 +1,6 @@
require openssl.inc
-PR = "r4"
+PR = "r5"
SRC_URI += "file://debian/ca.patch \
file://debian/config-hurd.patch;apply=no \
file://debian/debian-targets.patch \
diff --git a/meta/recipes-devtools/perl/perl_5.12.3.bb b/meta/recipes-devtools/perl/perl_5.12.3.bb
index 4b6b5a796b..671319c4e6 100644
--- a/meta/recipes-devtools/perl/perl_5.12.3.bb
+++ b/meta/recipes-devtools/perl/perl_5.12.3.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://Copying;md5=2b4c6ffbcfcbdee469f02565f253d81a \
# We need gnugrep (for -I)
DEPENDS = "virtual/db grep-native"
DEPENDS += "gdbm zlib"
-PR = "r3"
+PR = "r4"
# 5.10.1 has Module::Build built-in
PROVIDES += "libmodule-build-perl"
@@ -117,7 +117,7 @@ do_configure() {
rm -f config.sh-${TARGET_ARCH}-${TARGET_OS}
for i in ${WORKDIR}/config.sh \
${WORKDIR}/config.sh-${SITEINFO_BITS} \
- ${WORKDIR}/config.sh-${SITEINFO_BITS}-${SITEINFO_ENDIANESS}; do
+ ${WORKDIR}/config.sh-${SITEINFO_BITS}-${SITEINFO_ENDIANNESS}; do
cat $i >> config.sh-${TARGET_ARCH}-${TARGET_OS}
done
diff --git a/meta/recipes-qt/qt4/qt4-embedded.inc b/meta/recipes-qt/qt4/qt4-embedded.inc
index de311dca57..9b7e071e7a 100644
--- a/meta/recipes-qt/qt4/qt4-embedded.inc
+++ b/meta/recipes-qt/qt4/qt4-embedded.inc
@@ -3,7 +3,7 @@ SECTION = "libs"
LICENSE = "LGPLv2.1 | GPLv3"
HOMEPAGE = "http://qt.nokia.com"
DEPENDS += "directfb tslib"
-INC_PR = "r27"
+INC_PR = "r28"
QT_BASE_NAME ?= "qt4-embedded"
QT_BASE_LIB ?= "libqt-embedded"
diff --git a/meta/recipes-qt/qt4/qt4-x11-free.inc b/meta/recipes-qt/qt4/qt4-x11-free.inc
index e6169f3dcf..b8633de741 100644
--- a/meta/recipes-qt/qt4/qt4-x11-free.inc
+++ b/meta/recipes-qt/qt4/qt4-x11-free.inc
@@ -5,7 +5,7 @@ HOMEPAGE = "http://qt.nokia.com"
SECTION = "x11/libs"
DEPENDS += "virtual/libgl virtual/libx11 fontconfig libxft libxext libxrender libxrandr libxcursor"
-INC_PR = "r24"
+INC_PR = "r25"
QT_GLFLAGS ?= "${@base_contains('DISTRO_FEATURES', 'opengl', '-opengl', '-no-opengl', d)} "
QT_GLFLAGS_qemux86 = "-opengl"
diff --git a/meta/recipes-qt/qt4/qt4_arch.inc b/meta/recipes-qt/qt4/qt4_arch.inc
index 7f4be63bca..e8c8fabe68 100644
--- a/meta/recipes-qt/qt4/qt4_arch.inc
+++ b/meta/recipes-qt/qt4/qt4_arch.inc
@@ -17,9 +17,9 @@ def qt_arch(d):
def qt_endian(d):
import bb
- if bb.data.getVar('SITEINFO_ENDIANESS', d, True) == "le":
+ if bb.data.getVar('SITEINFO_ENDIANNESS', d, True) == "le":
return "-little-endian"
- elif bb.data.getVar('SITEINFO_ENDIANESS', d, True) == "be":
+ elif bb.data.getVar('SITEINFO_ENDIANNESS', d, True) == "be":
return "-big-endian"
else:
assert False