aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorTyler Hall <tylerwhall@gmail.com>2014-05-04 18:37:50 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-05-29 13:42:06 +0100
commitae49adc13db10cb39eeb9377eb4c60a4db436e00 (patch)
treed79d9de6a7bac110c3aaab5b2dabe64ae8cb3dd8 /meta
parent0903469ffd41c8e6a5ed8ba09817c004a16a477e (diff)
downloadopenembedded-core-contrib-ae49adc13db10cb39eeb9377eb4c60a4db436e00.tar.gz
python3: Substitute correct python version in shebang
If python2 and python3 are both available, scripts that are subject to this substitution can possibly run with the wrong python version. python3-config is one such script. (From OE-Core rev: 23849347d0fe60a01578efdd6c6e23ebb444dcd6) Signed-off-by: Tyler Hall <tylerwhall@gmail.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/python/python3-native_3.3.3.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python3-native_3.3.3.bb b/meta/recipes-devtools/python/python3-native_3.3.3.bb
index 7238eaf27d..0fd73498e8 100644
--- a/meta/recipes-devtools/python/python3-native_3.3.3.bb
+++ b/meta/recipes-devtools/python/python3-native_3.3.3.bb
@@ -71,6 +71,6 @@ do_install() {
# Make sure we use /usr/bin/env python
for PYTHSCRIPT in `grep -rIl ${bindir}/${PN}/python ${D}${bindir}/${PN}`; do
- sed -i -e '1s|^#!.*|#!/usr/bin/env python|' $PYTHSCRIPT
+ sed -i -e '1s|^#!.*|#!/usr/bin/env python3|' $PYTHSCRIPT
done
}