aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-06-22 20:05:02 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-07-01 15:38:21 +0100
commit942fb460339c9771e40d2e1bc36ac09b0ac39821 (patch)
treebf0b47c4fd050787d48141d4c71a828c48baebbe /meta
parent13518a25cbad122be4d3f15dbe87cc5a53ef5b1d (diff)
downloadopenembedded-core-contrib-942fb460339c9771e40d2e1bc36ac09b0ac39821.tar.gz
perl: fix for ODBM_File.so
Fixed for test case ../ext/ODBM_File/t/odbm.t: ok 1 - use ODBM_File; ok 2 - use Fcntl; ./perl: symbol lookup error: /usr/lib/perl/5.22.0/auto/ODBM_File/ODBM_File.so: undefined symbol: dbminit The checking "if -e $_.'/libgdbm_compat.so'" doesn't work when cross build, so always link libgdbm_compat, since perl depends on gdbm and we always have libgdbm_compat. Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/perl/perl/ext-ODBM_File-hints-linux.pl-link-libgdbm_compat.patch35
-rw-r--r--meta/recipes-devtools/perl/perl_5.22.0.bb1
2 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/perl/ext-ODBM_File-hints-linux.pl-link-libgdbm_compat.patch b/meta/recipes-devtools/perl/perl/ext-ODBM_File-hints-linux.pl-link-libgdbm_compat.patch
new file mode 100644
index 0000000000..994ef7013c
--- /dev/null
+++ b/meta/recipes-devtools/perl/perl/ext-ODBM_File-hints-linux.pl-link-libgdbm_compat.patch
@@ -0,0 +1,35 @@
+From ba4ed0b5b7baad5353c1e65b655f41d45e01c990 Mon Sep 17 00:00:00 2001
+From: Robert Yang <liezhi.yang@windriver.com>
+Date: Mon, 22 Jun 2015 20:00:11 -0700
+Subject: [PATCH] ext/ODBM_File/hints/linux.pl: link libgdbm_compat
+
+Fixed for test case ../ext/ODBM_File/t/odbm.t:
+ok 1 - use ODBM_File;
+ok 2 - use Fcntl;
+./perl: symbol lookup error: /usr/lib/perl/5.22.0/auto/ODBM_File/ODBM_File.so: undefined symbol: dbminit
+
+The checking "if -e $_.'/libgdbm_compat.so'" doesn't work when cross
+build, so always link libgdbm_compat, since perl depends on gdbm and we
+always have libgdbm_compat.
+
+Upstream-Status:Inappropriate [embedded specific]
+
+Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
+---
+ ext/ODBM_File/hints/linux.pl | 6 ------
+ 1 file changed, 6 deletions(-)
+
+diff --git a/ext/ODBM_File/hints/linux.pl b/ext/ODBM_File/hints/linux.pl
+index 204bba0..9271b45 100644
+--- a/ext/ODBM_File/hints/linux.pl
++++ b/ext/ODBM_File/hints/linux.pl
+@@ -1,8 +1,2 @@
+ # uses GDBM dbm compatibility feature - at least on SuSE 8.0
+-$self->{LIBS} = ['-lgdbm'];
+-
+-# Debian/Ubuntu have libgdbm_compat.so but not this file,
+-# so linking may fail
+-foreach (split / /, $Config{libpth}) {
+- $self->{LIBS}->[0] .= ' -lgdbm_compat' if -e $_.'/libgdbm_compat.so';
+-}
++$self->{LIBS} = ['-lgdbm -lgdbm_compat'];
diff --git a/meta/recipes-devtools/perl/perl_5.22.0.bb b/meta/recipes-devtools/perl/perl_5.22.0.bb
index da3dba6ebb..7c7041475f 100644
--- a/meta/recipes-devtools/perl/perl_5.22.0.bb
+++ b/meta/recipes-devtools/perl/perl_5.22.0.bb
@@ -59,6 +59,7 @@ SRC_URI += " \
file://config.sh-64-be \
file://make_ext.pl-fix-regenerate-makefile-failed-while-cc-.patch \
file://t-run-switches.t-perl5-perl.patch \
+ file://ext-ODBM_File-hints-linux.pl-link-libgdbm_compat.patch \
"
# Fix test case issues