aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>2015-05-04 09:43:00 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-05-07 13:14:35 +0100
commitf279f1df6429b0f76e5354c6f0f0b5c29f558edd (patch)
tree40ae23839875f004cb21b41567fe9570b92c74d7 /meta
parentc27a5a9ba649e7fcf681f6ac4575442e252fd29b (diff)
downloadopenembedded-core-contrib-f279f1df6429b0f76e5354c6f0f0b5c29f558edd.tar.gz
python3-native: Disable pip on native builds to fix Autobuilder issues
As Python-3.4 pip is required and installed by default, pips installation is bootstrapped using python wheels, this makes it complicated to patch and causes errors on the Autobuilders, since we don't need pip for python3-native, this disables it fixing the issues. Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/python/python3-native_3.4.2.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python3-native_3.4.2.bb b/meta/recipes-devtools/python/python3-native_3.4.2.bb
index 37399be69c..463957f8c1 100644
--- a/meta/recipes-devtools/python/python3-native_3.4.2.bb
+++ b/meta/recipes-devtools/python/python3-native_3.4.2.bb
@@ -42,7 +42,7 @@ inherit native
RPROVIDES += "python3-distutils-native python3-compression-native python3-textutils-native python3-core-native"
-EXTRA_OECONF_append = " --bindir=${bindir}/${PN}"
+EXTRA_OECONF_append = " --bindir=${bindir}/${PN} --without-ensurepip"
EXTRA_OEMAKE = '\
BUILD_SYS="" \