aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2015-11-10 22:34:01 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-11-25 08:01:34 +0000
commit4ff6b8cadec10e17dbf884a873a227e29944f5d1 (patch)
tree4186bd7c8001092bc4a97c5a6d7f1a88cb8cbbea /meta
parentc643fcf5152c50de130b16b567e2a9bad99546a1 (diff)
downloadopenembedded-core-contrib-4ff6b8cadec10e17dbf884a873a227e29944f5d1.tar.gz
systemd: chown hwdb.bin to root:root for do_rootfs
This is created by qemu for the do_rootfs case, which bypasses pseudo, so we need to correct the ownership. This fixes a warning issued by rootfs_check_host_user_contaminated. Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-core/systemd/systemd_225.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-core/systemd/systemd_225.bb b/meta/recipes-core/systemd/systemd_225.bb
index ea964131fb..0e89d221a8 100644
--- a/meta/recipes-core/systemd/systemd_225.bb
+++ b/meta/recipes-core/systemd/systemd_225.bb
@@ -411,6 +411,7 @@ pkg_postinst_udev-hwdb () {
if test -n "$D"; then
${@qemu_run_binary(d, '$D', '${base_bindir}/udevadm')} hwdb --update \
--root $D
+ chown root:root $D${sysconfdir}/udev/hwdb.bin
else
udevadm hwdb --update
fi