aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorJoshua Lock <josh@linux.intel.com>2008-10-31 15:20:31 +0000
committerJoshua Lock <josh@linux.intel.com>2008-10-31 15:25:24 +0000
commit25e5b72195a61cbb1bbbc3cbd3061fe570861d4c (patch)
tree01798dc535afe2d1a3aeec3756383f71d13c03c2 /meta
parent17bb6733b9c7c357191477475dca1a1359ca0fae (diff)
downloadopenembedded-core-contrib-25e5b72195a61cbb1bbbc3cbd3061fe570861d4c.tar.gz
libxml2: Fix a compilation error when using -D_FORTIFY_SOURCE=2 thanks Chenglan Huang
Diffstat (limited to 'meta')
-rw-r--r--meta/packages/libxml/files/libxml-nanohttp.patch13
-rw-r--r--meta/packages/libxml/libxml2-native_2.6.29.bb2
-rw-r--r--meta/packages/libxml/libxml2.inc3
-rw-r--r--meta/packages/libxml/libxml2_2.6.29.bb2
4 files changed, 17 insertions, 3 deletions
diff --git a/meta/packages/libxml/files/libxml-nanohttp.patch b/meta/packages/libxml/files/libxml-nanohttp.patch
new file mode 100644
index 0000000000..550e036db3
--- /dev/null
+++ b/meta/packages/libxml/files/libxml-nanohttp.patch
@@ -0,0 +1,13 @@
+Index: libxml2-2.6.29/nanohttp.c
+===================================================================
+--- libxml2-2.6.29.orig/nanohttp.c 2008-10-30 10:12:11.000000000 +0800
++++ libxml2-2.6.29/nanohttp.c 2008-10-30 10:12:30.000000000 +0800
+@@ -1585,7 +1585,7 @@
+ if (!strcmp(filename, "-"))
+ fd = 0;
+ else {
+- fd = open(filename, O_CREAT | O_WRONLY);
++ fd = open(filename, O_CREAT | O_WRONLY, 0644);
+ if (fd < 0) {
+ xmlNanoHTTPClose(ctxt);
+ return(-1);
diff --git a/meta/packages/libxml/libxml2-native_2.6.29.bb b/meta/packages/libxml/libxml2-native_2.6.29.bb
index 431d81d1d7..da79c9bb4e 100644
--- a/meta/packages/libxml/libxml2-native_2.6.29.bb
+++ b/meta/packages/libxml/libxml2-native_2.6.29.bb
@@ -1,6 +1,6 @@
require libxml2.inc
-PR = "r7"
+PR = "r8"
DEPENDS += "python-native"
diff --git a/meta/packages/libxml/libxml2.inc b/meta/packages/libxml/libxml2.inc
index 4e6e527603..e8b03cf02d 100644
--- a/meta/packages/libxml/libxml2.inc
+++ b/meta/packages/libxml/libxml2.inc
@@ -4,7 +4,8 @@ PRIORITY = "optional"
LICENSE = "MIT"
SRC_URI = "ftp://xmlsoft.org/libxml2/libxml2-${PV}.tar.gz \
- file://libxml-64bit.patch;patch=1"
+ file://libxml-64bit.patch;patch=1 \
+ file://libxml-nanohttp.patch;patch=1"
inherit autotools pkgconfig binconfig
diff --git a/meta/packages/libxml/libxml2_2.6.29.bb b/meta/packages/libxml/libxml2_2.6.29.bb
index 3b4bac673a..2f583c2c30 100644
--- a/meta/packages/libxml/libxml2_2.6.29.bb
+++ b/meta/packages/libxml/libxml2_2.6.29.bb
@@ -1,6 +1,6 @@
require libxml2.inc
-PR = "r6"
+PR = "r7"
export LDFLAGS += "-ldl"