aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2013-09-25 12:36:00 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-09-26 16:37:14 +0100
commit2ec171cb188601bf18c6c2895870907024b1c52a (patch)
treebb951b7bab125287753f7678ca8a1750fbc8a945 /meta
parentbdc6d3be6ffa4ed358153f9c9332b632324f5833 (diff)
downloadopenembedded-core-contrib-2ec171cb188601bf18c6c2895870907024b1c52a.tar.gz
gcc/libtool/perl: Fix various path to sed-native problems
If sed-native is built before these programs, hardcoded paths to sed-native can end up in scripts and other parts of the system which may cause issues if they are later used from sstate and sed-native is not installed. To avoid this, this patch changes the global site configuration to specify that plain "sed" is fine to be used. We need to spell this out for gcc since it doesn't see the site files since we don't autoreconf it. We can remove the values from libtool. We tell perl to use "/bin/sed" since it requires a path and the system sed should be just fine for it. [YOCTO #4971] Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/gcc/gcc-configure-common.inc1
-rw-r--r--meta/recipes-devtools/libtool/libtool-2.4.2.inc3
-rw-r--r--meta/recipes-devtools/libtool/libtool-native_2.4.2.bb1
-rw-r--r--meta/recipes-devtools/perl/perl-native_5.14.3.bb1
-rw-r--r--meta/site/common2
5 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-devtools/gcc/gcc-configure-common.inc b/meta/recipes-devtools/gcc/gcc-configure-common.inc
index b87ea62570e..dc44cc9f084 100644
--- a/meta/recipes-devtools/gcc/gcc-configure-common.inc
+++ b/meta/recipes-devtools/gcc/gcc-configure-common.inc
@@ -48,6 +48,7 @@ EXTRA_OECONF = "${@['--enable-clocale=generic', ''][d.getVar('USE_NLS', True) !=
${@get_gcc_mips_plt_setting(bb, d)} \
${@get_gcc_multiarch_setting(bb, d)}"
+export ac_cv_path_SED = 'sed'
export gcc_cv_collect2_libs = 'none required'
# We need to set gcc_cv_collect2_libs else there is cross-compilation badness
# in the config.log files (which might not get generated until do_compile
diff --git a/meta/recipes-devtools/libtool/libtool-2.4.2.inc b/meta/recipes-devtools/libtool/libtool-2.4.2.inc
index 92e49499dd3..5a67eeb9d18 100644
--- a/meta/recipes-devtools/libtool/libtool-2.4.2.inc
+++ b/meta/recipes-devtools/libtool/libtool-2.4.2.inc
@@ -26,9 +26,6 @@ SRC_URI = "${GNU_MIRROR}/libtool/libtool-${PV}.tar.gz \
SRC_URI[md5sum] = "d2f3b7d4627e69e13514a40e72a24d50"
SRC_URI[sha256sum] = "b38de44862a987293cd3d8dfae1c409d514b6c4e794ebc93648febf9afc38918"
-# Don't want paths to sed-native (or anything else) encoded
-CACHED_CONFIGUREVARS += "ac_cv_path_SED=sed"
-
do_compile_prepend () {
# Sometimes this file doesn't get rebuilt, force the issue
rm -f ${S}/libltdl/config/ltmain.sh
diff --git a/meta/recipes-devtools/libtool/libtool-native_2.4.2.bb b/meta/recipes-devtools/libtool/libtool-native_2.4.2.bb
index 18188ef7f34..df73f08e99e 100644
--- a/meta/recipes-devtools/libtool/libtool-native_2.4.2.bb
+++ b/meta/recipes-devtools/libtool/libtool-native_2.4.2.bb
@@ -8,7 +8,6 @@ SRC_URI += "file://prefix.patch"
inherit native
EXTRA_OECONF = " --with-libtool-sysroot=${STAGING_DIR_NATIVE}"
-CACHED_CONFIGUREVARS += "ac_cv_path_SED=/bin/sed"
do_configure_prepend () {
# Remove any existing libtool m4 since old stale versions would break
diff --git a/meta/recipes-devtools/perl/perl-native_5.14.3.bb b/meta/recipes-devtools/perl/perl-native_5.14.3.bb
index 9f0b8a1c194..c9ec2d26553 100644
--- a/meta/recipes-devtools/perl/perl-native_5.14.3.bb
+++ b/meta/recipes-devtools/perl/perl-native_5.14.3.bb
@@ -63,6 +63,7 @@ do_configure () {
-Di_syslog \
-Duseperlio \
-Dman3ext=3pm \
+ -Dsed=/bin/sed \
-Uafs \
-Ud_csh \
-Uusesfio \
diff --git a/meta/site/common b/meta/site/common
index 1214a13515a..5ccc14f8c95 100644
--- a/meta/site/common
+++ b/meta/site/common
@@ -17,3 +17,5 @@ shadow_cv_passwd_dir=${bindir}
# python: deactivate a runtime check for ipv6-support in python >=2.7.1 that fails when cross-compiling
ac_cv_buggy_getaddrinfo=no
+
+ac_cv_path_SED=sed