summaryrefslogtreecommitdiffstats
path: root/meta/recipes-webos/qt-features-webos/qt-features-webos.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2018-04-26 09:23:02 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2019-03-24 11:13:28 +0100
commite45f3d305e25ff2aef9e42697e583e6f69a9b6e6 (patch)
tree0bf698ed62d258d6e05d5a3129dea2e52b2d2121 /meta/recipes-webos/qt-features-webos/qt-features-webos.bb
parentc44fc9b620f762ce68441f834e1a157288a488e6 (diff)
downloadopenembedded-core-contrib-e45f3d305e25ff2aef9e42697e583e6f69a9b6e6.tar.gz
meta-webosose: import recipes which often reproduce Yocto #12434
* just temporary to make it easier to reproduce, import big part of meta-webosose and some recipes from meta-oe * luna-init: /luna-init-fonts/usr/share/fonts/PreludeCompWGL-Light.ttf is owned by uid 1001, which is the same as the user running bitbake. This may be due to host contamination * qml-webos-framework: /qml-webos-framework/usr/share/dbus-1/system-services/com.webos.qml-app.service is owned by uid 1101, which is the same as the user running bitbake. This may be due to host contamination [host-user-contaminated] * to reproduce this you can try to use something like this: export COMP=luna-init; for i in `seq -w 1 999`; do echo $i; bitbake -v -v -DDDD -f -c package ${COMP} 2>${COMP}-logerr.$i >${COMP}-log.$i; bitbake -v -v -DDDD -f -c package_qa ${COMP} 2>${COMP}-logerr.qa.$i >${COMP}-log.qa.$i || { cp -ra BUILD/work/i586-oe-linux/${COMP}/ ${COMP}-workdir-$i; bitbake -c cleansstate ${COMP} ; } done export COMP=qml-webos-framework; for i in `seq -w 1 999`; do echo $i; bitbake -v -v -DDDD -f -c package ${COMP} 2>${COMP}-logerr.$i >${COMP}-log.$i; bitbake -v -v -DDDD -f -c package_qa ${COMP} 2>${COMP}-logerr.qa.$i >${COMP}-log.qa.$i || { cp -ra BUILD/work/i586-oe-linux/${COMP}/ ${COMP}-workdir-$i; bitbake -c cleansstate ${COMP} ; } done Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta/recipes-webos/qt-features-webos/qt-features-webos.bb')
-rw-r--r--meta/recipes-webos/qt-features-webos/qt-features-webos.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-webos/qt-features-webos/qt-features-webos.bb b/meta/recipes-webos/qt-features-webos/qt-features-webos.bb
new file mode 100644
index 0000000000..984ba7dc25
--- /dev/null
+++ b/meta/recipes-webos/qt-features-webos/qt-features-webos.bb
@@ -0,0 +1,36 @@
+# Copyright (c) 2013-2018 LG Electronics, Inc.
+
+SUMMARY = "Common Qt features for webOS components"
+AUTHOR = "Anupam Kaul <anulam.kaul@lge.com>"
+SECTION = "webos/base"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+DEPENDS = "qtbase"
+
+WEBOS_VERSION = "1.0.0-1_67a99fc04d01e3025d137f7d50b0aa15016c4525"
+PR = "r4"
+
+inherit webos_qmake5
+inherit webos_enhanced_submissions
+inherit webos_public_repo
+
+SRC_URI = "${WEBOSOSE_GIT_REPO_COMPLETE}"
+S = "${WORKDIR}/git"
+
+SRC_URI += "file://qt.patch"
+
+FILES_${PN}-dev += "${OE_QMAKE_PATH_QT_ARCHDATA}/mkspecs"
+
+# An empty package is needed to satisfy package dependencies when building bdk.
+ALLOW_EMPTY_${PN} = "1"
+
+BBCLASSEXTEND = "native"
+
+do_configure_class-native() {
+ ${OE_QMAKE_QMAKE} ${OE_QMAKE_DEBUG_OUTPUT} -r ${S}/tools/generate_qmap
+}
+
+do_install_class-native() {
+ oe_runmake install INSTALL_ROOT=${D}
+}