aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2018-07-23 15:37:07 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-07-26 13:16:31 +0100
commitdaa496e7104e3f06bc5192bb4ec7d894b22dba5d (patch)
tree3c9c999310187e7610ee6ee4e73cdd9272cd2eca /meta/recipes-support
parenta13d3314cd4ddc812c3ac2904c8f563f7462878a (diff)
downloadopenembedded-core-contrib-daa496e7104e3f06bc5192bb4ec7d894b22dba5d.tar.gz
apr: fix ptest hangs since enter non-terminating loop
ptest hangs in teststr since enter non-terminating loop, fixed by a backport patch Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/apr/apr/0008-apr-fix-ptest-hang-in-teststr.patch32
-rw-r--r--meta/recipes-support/apr/apr_1.6.3.bb1
2 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-support/apr/apr/0008-apr-fix-ptest-hang-in-teststr.patch b/meta/recipes-support/apr/apr/0008-apr-fix-ptest-hang-in-teststr.patch
new file mode 100644
index 0000000000..6809fa60b0
--- /dev/null
+++ b/meta/recipes-support/apr/apr/0008-apr-fix-ptest-hang-in-teststr.patch
@@ -0,0 +1,32 @@
+From 036f90748247417dbfa714b1b912ca7dd4053f04 Mon Sep 17 00:00:00 2001
+From: Changqing Li <changqing.li@windriver.com>
+Date: Mon, 23 Jul 2018 14:12:35 +0800
+Subject: [PATCH] apr: fix ptest hang in teststr
+
+ptest hang in teststr since turns into a non-terminating loop,
+fix by below backported patch.
+
+Upstream-Status: Backport[https://github.com/apache/apr/commit/
+ 2e8fbff4ecf82d0decf6baf774c209948f2f4998?diff=unified]
+
+Signed-off-by: Changqing Li <changqing.li@windriver.com>
+---
+ test/teststr.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/test/teststr.c b/test/teststr.c
+index d9a5054..951a830 100644
+--- a/test/teststr.c
++++ b/test/teststr.c
+@@ -307,7 +307,7 @@ static void overflow_strfsize(abts_case *tc, void *data)
+ for (; off < 999999999; off += 999) {
+ apr_strfsize(off, buf);
+ }
+- for (off = 1; off < LONG_MAX && off > 0; off *= 2) {
++ for (off = LONG_MAX; off > 1; off /= 2) {
+ apr_strfsize(off, buf);
+ apr_strfsize(off + 1, buf);
+ apr_strfsize(off - 1, buf);
+--
+2.7.4
+
diff --git a/meta/recipes-support/apr/apr_1.6.3.bb b/meta/recipes-support/apr/apr_1.6.3.bb
index 87b878723b..e044c4a9a5 100644
--- a/meta/recipes-support/apr/apr_1.6.3.bb
+++ b/meta/recipes-support/apr/apr_1.6.3.bb
@@ -18,6 +18,7 @@ SRC_URI = "${APACHE_MIRROR}/apr/${BPN}-${PV}.tar.bz2 \
file://0005-configure.in-fix-LTFLAGS-to-make-it-work-with-ccache.patch \
file://0006-apr-fix-off_t-size-doesn-t-match-in-glibc-when-cross.patch \
file://0007-explicitly-link-libapr-against-phtread-to-make-gold-.patch \
+ file://0008-apr-fix-ptest-hang-in-teststr.patch \
"
SRC_URI[md5sum] = "12f2a349483ad6f12db49ba01fbfdbfa"