aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2018-05-17 21:35:34 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-05-29 11:25:03 +0100
commit2f0f9b7f0b209798a74ee7fc8eafde5a109364b9 (patch)
tree4b81f9b6ad76c505ce2071133d9395d2f2eabaf9 /meta/recipes-support
parent14910c5a215f434b2df47ca38902192f04f6b38a (diff)
downloadopenembedded-core-contrib-2f0f9b7f0b209798a74ee7fc8eafde5a109364b9.tar.gz
pinentry: let autotools.bbclass handle --disable-dependency-tracking
autotools.bbclass adds --disable-dependency-tracking to the configure command line by default, so there's no need for individual recipes to do so. Also make some minor recipe formatting cleanups. Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/pinentry/pinentry_1.1.0.bb11
1 files changed, 6 insertions, 5 deletions
diff --git a/meta/recipes-support/pinentry/pinentry_1.1.0.bb b/meta/recipes-support/pinentry/pinentry_1.1.0.bb
index 1eaa261f75..4116efc76f 100644
--- a/meta/recipes-support/pinentry/pinentry_1.1.0.bb
+++ b/meta/recipes-support/pinentry/pinentry_1.1.0.bb
@@ -8,8 +8,6 @@ HOMEPAGE = "http://www.gnupg.org/related_software/pinentry/index.en.html"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=cbbd794e2a0a289b9dfcc9f513d1996e"
-inherit autotools pkgconfig
-
DEPENDS = "gettext-native libassuan libgpg-error"
UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
@@ -21,9 +19,7 @@ SRC_URI = "${GNUPG_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \
SRC_URI[md5sum] = "3829315cb0a1e9cedc05ffe6def7a2c6"
SRC_URI[sha256sum] = "68076686fa724a290ea49cdf0d1c0c1500907d1b759a3bcbfbec0293e8f56570"
-EXTRA_OECONF = "--disable-rpath --disable-dependency-tracking \
- --disable-pinentry-qt5 \
-"
+inherit autotools pkgconfig
PACKAGECONFIG ??= "ncurses libcap"
@@ -35,4 +31,9 @@ PACKAGECONFIG[gtk2] = "--enable-pinentry-gtk2, --disable-pinentry-gtk2, gtk+ gli
#To use libsecret, add meta-gnome
PACKAGECONFIG[secret] = "--enable-libsecret, --disable-libsecret, libsecret"
+EXTRA_OECONF = " \
+ --disable-rpath \
+ --disable-pinentry-qt5 \
+"
+
BBCLASSEXTEND = "native"