aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorbaali <shantanu@senic.com>2017-09-26 00:50:34 +0530
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-09-26 10:14:17 +0100
commitbcc8560300c8b1218b1f3709f5a7732e17fbfa46 (patch)
tree2456be73a33b810e3ad071a15d56ed2f4b4645b0 /meta/recipes-support
parentf28e8131f69913ff90ed210c7a58726d3ef37db6 (diff)
downloadopenembedded-core-contrib-bcc8560300c8b1218b1f3709f5a7732e17fbfa46.tar.gz
curl: Added option to enable http2 protocol.
With default --without-nghttp2 flag set there was no way to get http2 protocol support using nghttp2 library. Instead moved it to PACKAGECONFIG options Signed-off-by: baali <shantanu@senic.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/curl/curl_7.54.1.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-support/curl/curl_7.54.1.bb b/meta/recipes-support/curl/curl_7.54.1.bb
index 54f3b667c8..04aeee72d1 100644
--- a/meta/recipes-support/curl/curl_7.54.1.bb
+++ b/meta/recipes-support/curl/curl_7.54.1.bb
@@ -48,13 +48,13 @@ PACKAGECONFIG[tftp] = "--enable-tftp,--disable-tftp,"
PACKAGECONFIG[threaded-resolver] = "--enable-threaded-resolver,--disable-threaded-resolver"
PACKAGECONFIG[zlib] = "--with-zlib=${STAGING_LIBDIR}/../,--without-zlib,zlib"
PACKAGECONFIG[krb5] = "--with-gssapi,--without-gssapi,krb5"
+PACKAGECONFIG[nghttp2] = "--with-nghttp2,--without-nghttp2,nghttp2"
EXTRA_OECONF = " \
--enable-crypto-auth \
--with-ca-bundle=${sysconfdir}/ssl/certs/ca-certificates.crt \
--without-libmetalink \
--without-libpsl \
- --without-nghttp2 \
"
do_install_append() {