aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2015-07-11 00:30:24 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-07-16 15:08:44 +0100
commitc9883a572eb92e9b846e9021495e0715fb2a4db7 (patch)
tree9fef881623f0c56905e44bf0ed0cb3a316ad22d8 /meta/recipes-support
parent6d098587415be098913a3b551b0b7ee8c0270274 (diff)
downloadopenembedded-core-contrib-c9883a572eb92e9b846e9021495e0715fb2a4db7.tar.gz
gnupg: fix build of GPLv2 version of gnupg with gcc 5
Force gcc's traditional handling of inline to avoid issues with gcc 5. Upstream gnupg has a more specific fix, however it was made after gnupg was relicensed to GPLv3 so may be unsafe to backport directly. http://git.gnupg.org/cgi-bin/gitweb.cgi?p=gnupg.git;a=commitdiff;h=5093bed27580e608de073bcc5953bd76b6b8b2de Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/gnupg/gnupg_1.4.7.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-support/gnupg/gnupg_1.4.7.bb b/meta/recipes-support/gnupg/gnupg_1.4.7.bb
index aef515d534..6999f81f84 100644
--- a/meta/recipes-support/gnupg/gnupg_1.4.7.bb
+++ b/meta/recipes-support/gnupg/gnupg_1.4.7.bb
@@ -81,6 +81,9 @@ EXTRA_OECONF = "--disable-ldap \
ac_cv_sys_symbol_underscore=no \
"
+# Force gcc's traditional handling of inline to avoid issues with gcc 5
+CFLAGS += "-fgnu89-inline"
+
do_install () {
autotools_do_install
install -d ${D}${docdir}/${BPN}