aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2015-07-15 18:58:07 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-07-20 10:38:59 +0100
commit974c8266b30ae114ab331f0ce39fd0fcf4868f1a (patch)
treebd46373de773f72d4ca53e9fd53158640530c175 /meta/recipes-support
parentaa6f5da8d42deb3d3b98209dc716b5a116d22d48 (diff)
downloadopenembedded-core-contrib-974c8266b30ae114ab331f0ce39fd0fcf4868f1a.tar.gz
libcap: avoid losing default Large File Support CFLAGS
-D_LARGEFILE64_SOURCE and -D_FILE_OFFSET_BITS=64 are present in the default libcap CFLAGS. Add them to the OE CFLAGS too, so that they are still in effect when the OE CFLAGS over-ride the defaults. Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/libcap/libcap_2.24.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-support/libcap/libcap_2.24.bb b/meta/recipes-support/libcap/libcap_2.24.bb
index e8ae7ce9ab..161bb702c3 100644
--- a/meta/recipes-support/libcap/libcap_2.24.bb
+++ b/meta/recipes-support/libcap/libcap_2.24.bb
@@ -41,6 +41,9 @@ EXTRA_OEMAKE = " \
EXTRA_OEMAKE_append_class-target = " SYSTEM_HEADERS=${STAGING_INCDIR}"
+# these are present in the libcap defaults, so include in our CFLAGS too
+CFLAGS += "-D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64"
+
do_compile() {
oe_runmake ${EXTRA_OECONF}
}