aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorChristopher Larson <kergoth@gmail.com>2015-08-24 15:19:44 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-08-30 12:34:19 +0100
commit5a14d4f981c2c12c274fade518d23706dca5889b (patch)
treefe1669bc87c0677103be975b8b0c5467f48aa09e /meta/recipes-support
parente43a47eb695050d04809ff54af14066acba6ec27 (diff)
downloadopenembedded-core-contrib-5a14d4f981c2c12c274fade518d23706dca5889b.tar.gz
libatomic-ops: move to recipes-support, fix recipe name
- This recipe is useful for more than just pulseaudio, so move it to recipes-support. - Rename to the correct upstream name, which corresponds to the library name. Keep a PROVIDES of libatomics-ops for compatibility. (From OE-Core rev: 5014de67fa6da1672626e3ec92fc51430fca3262) Signed-off-by: Christopher Larson <kergoth@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/bdwgc/bdwgc_7.4.2.bb2
-rw-r--r--meta/recipes-support/libatomic-ops/libatomic-ops_7.4.2.bb29
-rw-r--r--meta/recipes-support/libunwind/libunwind.inc2
3 files changed, 31 insertions, 2 deletions
diff --git a/meta/recipes-support/bdwgc/bdwgc_7.4.2.bb b/meta/recipes-support/bdwgc/bdwgc_7.4.2.bb
index 23ec95419c..1ca8cf77eb 100644
--- a/meta/recipes-support/bdwgc/bdwgc_7.4.2.bb
+++ b/meta/recipes-support/bdwgc/bdwgc_7.4.2.bb
@@ -36,6 +36,6 @@ inherit autotools pkgconfig
# by default use external libatomic-ops
PACKAGECONFIG ??= "libatomic-ops"
-PACKAGECONFIG[libatomic-ops] = "--with-libatomic-ops=yes,--with-libatomic-ops=no,libatomics-ops"
+PACKAGECONFIG[libatomic-ops] = "--with-libatomic-ops=yes,--with-libatomic-ops=no,libatomic-ops"
BBCLASSEXTEND = "native nativesdk"
diff --git a/meta/recipes-support/libatomic-ops/libatomic-ops_7.4.2.bb b/meta/recipes-support/libatomic-ops/libatomic-ops_7.4.2.bb
new file mode 100644
index 0000000000..4d0e299f4f
--- /dev/null
+++ b/meta/recipes-support/libatomic-ops/libatomic-ops_7.4.2.bb
@@ -0,0 +1,29 @@
+SUMMARY = "A library for atomic integer operations"
+HOMEPAGE = "https://github.com/ivmai/libatomic_ops/"
+SECTION = "optional"
+PROVIDES += "libatomics-ops"
+LICENSE = "GPLv2 & MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
+ file://doc/LICENSING.txt;md5=e00dd5c8ac03a14c5ae5225a4525fa2d \
+ "
+
+SRC_URI = "http://www.ivmaisoft.com/_bin/atomic_ops/libatomic_ops-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "1d6538604b314d2fccdf86915e5c0857"
+SRC_URI[sha256sum] = "04fa615f62992547bcbda562260e28b504bc4c06e2f985f267f3ade30304b5dd"
+
+S = "${WORKDIR}/libatomic_ops-${PV}"
+
+ALLOW_EMPTY_${PN} = "1"
+
+ARM_INSTRUCTION_SET = "arm"
+
+inherit autotools pkgconfig
+
+do_install_append() {
+ # those contain only docs, not necessary for now.
+ install -m 0755 -d ${D}${docdir}
+ mv ${D}${datadir}/libatomic_ops ${D}${docdir}/${BPN}
+}
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta/recipes-support/libunwind/libunwind.inc b/meta/recipes-support/libunwind/libunwind.inc
index c8eab5882d..6660af22c5 100644
--- a/meta/recipes-support/libunwind/libunwind.inc
+++ b/meta/recipes-support/libunwind/libunwind.inc
@@ -2,7 +2,7 @@ DESCRIPTION = "a portable and efficient C programming interface (API) to determi
HOMEPAGE = "http://www.nongnu.org/libunwind"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=3fced11d6df719b47505837a51c16ae5"
-DEPENDS += "libatomics-ops"
+DEPENDS += "libatomic-ops"
SRC_URI = "${SAVANNAH_NONGNU_MIRROR}/${BPN}/${BPN}-${PV}.tar.gz"